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This section describes the commissioning process for Multiroom System Manager
projects.
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Chapter 1. Target Audience
Commissioning Engineers
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Chapter 2. Prerequisites
A System Builder Technician License is required to configure a Multiroom system.

Before commissioning, you should have completed the following Learning@Signify learning paths:

• Dynalite - System Builder Foundation Training

• Architecture STR - Commissioning & Deployment

This document also references the Architecture STR - System Architecture & Design learning path.
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Chapter 3. Design Verification
System commissioning starts after the hotel developer has agreed to the features, design, and
commercial details. This involves configuring the required mockup room jobs so that the devices can be
programmed in the factory and installed with a standardized approach.

Commissioning then progresses to a temporary hotel job to allow end-to-end verification of all features.
Commissioning is completed by creating a single hotel job file that is loaded into the onsite System
Manager Server.

3.1. Recommended Process
This section outlines the tasks and tools for each phase of the commissioning process.

Phase Task Tools

Commercial Identify customer requirements • Project intake form

• Room alerts configuration intake form

System Design Translate requirements into
hardware design

• Device Specification Sheets

• Room Bill Of Quantities (BOQ)

• Network Architecture and Site BOQ

Provide quote • Proposal Pricing Tool

• Quotation

Mockup Room
Commissioning

Prepare mockup room • Room layout

• Hardware BOQ

• Hardware single-line drawing

• Circuit allocation table

• Luminaire schedule

• Room profile floor plan

• Electrical drawings with indicative wiring
arrangement

• Device Installation Instructions
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Phase Task Tools

Define room logic • STR Template Library

• Mockup room job files

• Panel design and engraving

• Preset scene definitions

• Integration descriptions

• Mockup room features table

• Room controller IP address table*

• Room mapping table

* The room controller IP address table is not
required when using DHCP (Port Editor > Use
static IP address is set to False).

Test interoperability • Third-party luminaire Interoperability test
report and waiver

Complete Hotel Job file • Mockup room sign-off sheet
(release for manufacturing)

• Mockup room job files

• Hotel job file

• Notional energy load sign-off sheet

• Room controller IP address table*

• Floor gateway IP address table

• DIP switch settings table

• Site private key text file (must be kept secure)

* The room controller IP address table is not
required when using DHCP (Port Editor > Use
static IP address is set to False).

Deployment Installation testing • System installation guide

• Room layout

• Electrical drawings

• Gateway IP address table

• Snagging list

System Manager setup • System Manager installation files

• Room mapping table

• Hotel job file

3.2. Commercial phase
In the Commercial phase of the project, the System Designer identifies the customer requirements by
completing the Project intake form and the Room alerts configuration intake form.
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The Intake Forms are simple Excel spreadsheets to help gather the customer requirements or summarize
a tender request. The step-by-step format allows you to review all the available features together with
the customer. Guided by system features and hotel room profiles, it helps you align features with
customer needs and focus on value rather than specification.

3.2.1. Project reference tools

• Project intake form

• Room alerts configuration intake form

3.3. System design phase
In the design phase, the System Engineer translates the customer requirements into a specific feature
set to be included in the quotation. They decide on the network architecture and produce a hardware
BOQ for each room profile and for the site. To complete the design phase, the Proposal Manager prices
the hardware design and feature offerings to produce a quotation.

Front-of-house, back-of-house, and architectural lighting can also be offered as part of the project.

3.3.1. Project reference tools

• Device Specification Sheets

• Room BOQ

• Network architecture and site BOQ

• Proposal pricing tool)

• Quotation


Before proceeding, refer to the Architecture STR - System Architecture & Design
learning pathway to ensure the design is STR compliant.

3.3.2. System building blocks

Ethernet gateway

An Ethernet gateway connects the SM server to a group of up to 25 rooms. Although they are referred
to as floor gateways, they are centrally located in the server room.

Room controller

• The design of every room must include one DDRC-GRMS-E controller.

• Additional Dynalite load controllers may be added if more circuits are required.

• If eight or fewer dimming circuits are required a DDRC-GRMS-E paired with a DDMC802 is often the
best choice.

Expansions

• Depending on the required control protocols you can add one or more expansion controllers:

◦ DDRC810DT-GL relay controller.

◦ DDMC802 multipurpose controller with the appropriate control modules.

◦ DDBC120-DALI or DDBC320-DALI for DALI Addressable control.
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◦ DDBC1200 for 1-10V/DSI/DALI Broadcast control.

◦ DDFCUC fan coil unit controller for controlling air conditioning.

Sensors

• A core function of the system is determining real-time occupancy. This is used to move the room
between states (Occupied/Unoccupied), which have parameters attached for temperature, lighting,
power, curtains, etc. To achieve this, we need adequate sensor coverage combined with our tasking
logic.

• We recommend using a DUS360 sensor for cost and coverage balance, but any Dynalite sensor may
be used.

• In most standard rooms, two sensors are sufficient: Bedroom and Bathroom. In suites and large
rooms, you can expand the design with additional sensors as required.

• The AntiStumble feature uses the standard sensor with a lens cover, recessed into the wall or
bedside table.

User Interfaces and Additions

• One AntumbraDisplay is recommended for HVAC control. Other user interfaces can be added in
accordance with the design requirements.

• If you have wake-up lighting or are supporting multiple languages, AntumbraDisplay is a good
choice for beside panels.

• We recommend separating status/service and lighting control functions for guest clarity. In most
cases it is good practice to use four button panels, especially where used as master panels at the
entrance. Just because we can add a lot of functions to one panel doesn’t mean we always should.

• A DLLI8I8O or DDRC-GRMS-E is required to drive the room status indicators on a corridor
panel/doorbell and for any third-party panels.

• We can source additional third-party environmental sensors such as a humidity sensor, if specified.

Control cable power

• In a Dynalite network, all the controllers contribute power, and all other devices consume it.

• We recommend that you calculate the network current in guestrooms to check that there is
sufficient power available on the DyNet loop for all panels and sensors.

• Our room BOQ template includes this calculation and allows you to build multiple room profiles
easily.

• Where required, you can add a DyNet power supply. It is better to not need one as it adds cost with
no additional features for end users.

HVAC

There are two main types of HVAC control commonly found in hotels:

1. FCU + Piped Water (Chilled/Heated)

◦ Most commonly found in larger hotels (200+ rooms), this consists of central coolers/heaters and
piped water around the building.

◦ Valves in the room allow the water to pass through a Fan Coil Unit which cools/heats the air and
blows it in to the room.

◦ Our FCU controllers provide everything needed for these requirements:

▪ Hot and Cold Valve control – power + (open/closed or variable 0-10 V or 0-24 V).
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▪ FCU fan motor control (Off/Low/Medium/High).

▪ Configurable internal dead band logic to manage the achievement and maintenance of
temperature setpoints.

▪ Dry contact inputs for balcony doors, drip trays, filter sensors, etc.

2. VRF/Split Units

◦ Most commonly found in smaller hotels, these are often closed systems from consumer brands.

◦ Fortunately, they almost always offer BACnet integration at the server level. With this link, we
can either:

a. Still provide the thermostat and pass setpoint and actual temperatures back for them to
manage.
OR

b. Only send room state changes to trigger their system to shift between presets.

Example luxury room BOQ

Quantity Device Description

Relay Controllers

1 x DDRC-GRMS-E
Room Controller

• 7 switched lighting circuits.

• 2 x 20 A switched circuits for GPO and Air
Conditioning.

• 2 dual curtain control relay channels.

• 64 DMX Tx lighting channels.

• 18 Dry contact inputs

• 4 Digital outputs

• UL924 input

• Ethernet Port

Multipurpose Controllers

1 x DDMC802 • 8 channel multipurpose controller supports
switched and dimmable loads up to 16 A total.

• 8 Dry contact inputs

Integration Devices

1 x DDFCUC • 0-10 V or 0-24 V control of the FCU hot and
cold-water valve

Sensors

4 x DUS360CR • Recessed 360° multifunction sensor for guest
detection in bedroom and bathroom. Also
used for AntiStumble in combination with
DUS180WR cover plate.

2 x DUS180WR • Wall-mounted cover plate enabling 180° multi
sensor for AntiStumble night lighting.

User Interfaces
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Quantity Device Description

4 x AntumbraButton &
DACM

• 6-button backlit panel with temperature
sensor, proximity sensor, and indicators to
show which scene is active. For entrance,
bathroom, bedside left and bedside right.

1 x AntumbraDisplay &
DACM

• 6-button backlit panel with LCD screen,
temperature sensor, proximity sensor, and
indicators used for HVAC control, displaying
the current and set temperature, or the time
and alarm status.

1 x Corridor panel • Third-party panel with Doorbell and
DND/MUR indicators.

Example Site BOQ

Quantity Device Description

Gateways

10 x PDDEG-S Ethernet Gateway • Ethernet gateway to connect floors to building
trunk network.

Computers

1 x Windows Server with licensed
Multiroom System Manager.

• Central management and monitoring software
to run on Windows Server or permanently
running PC.

• Browser-accessible dashboard providing real-
time visibility of room status, system health,
alerts, and event timeline.

3.3.3. Architecture

The system is comprised of room devices connected to a room controller in each guestroom. The rooms
are then connected via floor Ethernet gateways to the System Manager server, which also integrates
with other hotel systems.

Fast deployment is achieved with templated room configurations. By setting the DIP switches on the
underside of the DDRC-GRMS-E, the installer can easily configure a unique box number. This also sets
the box number range and area number range for devices in the room.

Floor gateways and DDRC-GRMS-E room controllers are given a unique IP address (IPv4 or IPv6) within a
site-specific address range made available by the building’s IT administrator. This is recorded in the
Room IP address table.

Ethernet to the room controller

One  Ethernet gateway per floor is connected via Ethernet/fibre to a  DDRC-GRMS-E room
controller, then via an RS-485 sub-network to the room devices.
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 Fibre connection requires an Optical Network Terminal (ONT).

DyNet addressing

The room controller DIP switch selects the following DyNet addressing:

• Box number for the room controller.

• Box number offset within the room.

• Area offset within the room.

Area Distribution Example

Default Area Offset Multiplier = 20

20 areas per room x 50 rooms per floor = 1,000 areas per floor
1000 areas per floor x 64 floors = 64,000 areas total

50 rooms per floor x 64 floors (or other combinations): 3,200 rooms



The example would only have 48 rooms per floor due to not using DIP Switch setting 0
(zero) and the formula:
Offset = (DIP switch + 1) x Multiplier, meaning that Room 1 is allocated to areas 40 -
59.
Hence, Areas 0 - 19 and 20 – 39 are not used.


Within each room the first two areas are not used (Area 0 = all areas, Area 1 =
unassigned area)


Twenty areas are recommended for typical guestrooms and forty or more areas for
larger suites.
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 You can choose other floor ranges to suit different sized hotels.

 Each floor Ethernet gateway supports connections for 25 DDRC-GRMS-E controllers.



The DDRC-GRMS-E has two sets of DIP switches labelled ID1 and ID2.

• ID1 sets the DyNet addressing (room offset).

• ID2 sets the Floor Gateway IP addressing in accordance with the Gateway
Mapping.

Example DyNet addressing

The standard trunk-and-spur architecture employs address ranges with floor offsets and room offsets as
in the below example (assuming floor offset = 1000 and room offset = 20):

• Highest room number per floor = 48

• Highest area number range per floor = 980-999

Floor EG 

Offset

Parameters

1 1000 GRMS Rm# L1 -  Rm1 L1 -  Rm2 L1 -  Rm3 L1 -  Rm4 L1 -  Rm5 L1 -  Rm6 L1 -  Rm7 L1 -  Rm8 L1 -  Rm9 L1 -  Rm10

DIP Swit ch 1 2 3 4 5 6 7 8 9 10

Area Range 40- 59 60-79 80- 99 100- 119 120- 139 140- 159 160- 179 180- 199 200- 219 220- 239

Area Range  

wit h Of f set

1040- 1059 1060- 1079 108 0- 1099 1100- 1119 1120- 1139 1140- 1159 1160- 1179 1180- 1199 1200- 1219 1220- 1239

2 2000 GRMS Rm# L2 -  Rm1 L2 -  Rm2 L2 -  Rm3 L2 -  Rm4 L2 -  Rm5 L2 -  Rm6 L2 -  Rm7 L2 -  Rm8 L2 -  Rm9 L2 -  Rm10

DIP Swit ch 1 2 3 4 5 6 7 8 9 10

Area Range 40- 59 60-79 80- 99 100- 119 120- 139 140- 159 160- 179 180- 199 200- 219 220- 239

Area Range  

wit h Of f set

2040- 2059 2060- 2079 208 0- 2099 2100- 2119 2120- 2139 2140- 2159 2160- 2179 2180- 2199 2200- 2219 2220- 2239

3 300 0 GRMS Rm# L3 -  Rm1 L3 -  Rm2 L3 -  Rm3 L3 -  Rm4 L3 -  Rm5 L3 -  Rm6 L3 -  Rm7 L3 -  Rm8 L3 -  Rm9 L3 -  Rm10

DIP Swit ch 1 2 3 4 5 6 7 8 9 10

Area Range 40- 59 60-79 80- 99 100- 119 120- 139 140- 159 160- 179 180- 199 200- 219 220- 239

Area Range  

wit h Of f set

3040- 3059 3060- 3079 308 0- 3099 3100- 3119 3120- 3139 3140- 3159 3160- 3179 3180- 3199 3200- 3219 3220- 3239

4 4000 GRMS Rm# L4 -  Rm1 L4 -  Rm2 L4 -  Rm3 L4 -  Rm4 L4 -  Rm5 L4 -  Rm6 L4 -  Rm7 L4 -  Rm8 L4 -  Rm9 L4 -  Rm10

DIP Swit ch 1 2 3 4 5 6 7 8 9 10

Area Range 40- 59 60-79 80- 99 100- 119 120- 139 140- 159 160- 179 180- 199 200- 219 220- 239

Area Range  

wit h Of f set

4040- 4059 4060- 4079 408 0- 4099 4100- 4119 4120- 4139 4140- 4159 4160- 4179 4180- 4199 4200- 4219 4220- 4239

5 5000 GRMS Rm# L5 -  Rm1 L5 -  Rm2 L5 -  Rm3 L5 -  Rm4 L5-  Rm5 L5 -  Rm6 L5 -  Rm7 L5 -  Rm8 L5 -  Rm9 L5 -  Rm10

DIP Swit ch 1 2 3 4 5 6 7 8 9 10

Area Range 40- 59 60-79 80- 99 100- 119 120- 139 140- 159 160- 179 180- 199 200- 219 220- 239

Area Range  

wit h Of f set

5040-5 059 5060-5 079 508 0-5 099 5100- 5119 5120- 5139 5140- 5159 5160- 5179 5180- 5199 5200- 5219 5220- 5239

IP addressing

When an IPv4-based architecture is selected for the project:

1. The floor IP address is programmed into the Ethernet gateway (PDDEG-S) on the floor.
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2. The room IP address is programmed into the DDRC-GRMS-E controller in the room.

IPv4 Example

Ethernet gateway Floor IPv4 address

Ground Floor 192.168.0.x

First Floor 192.168.1.x

Second Floor 192.168.2.x

Ground floor room Room IPv4 address

Room 1 192.168.0.1

Room 2 192.168.0.2

Room 3 192.168.0.3

When an IPv6-based architecture is selected for the project:

1. The floor IPv6 multicast address is programmed into the Ethernet gateway (PDDEG-S) on the floor.

2. The DDRC-GRMS-E IPv6 address is automatically set based on its MAC address.

IPv6 Example

Ethernet Gateway Multicast IPv6 address

Ground Floor FF12::4479:2:0:1

First Floor FF12::4479:2:0:2

Second Floor FF12::4479:2:0:3


The gateway mapping feature enables the IP address of every floor gateway to be
programmed into every DDRC-GRMS-E so the connection can be selected by the ID2
DIP switches.
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Chapter 4. Off-Site Configuration
4.1. Mockup room commissioning process
Multiroom System Manager offers a range of core features and additional feature options. The features
chosen by the customer form the basis of the mockup room job file, which contains the configuration
for all devices in the specified room profile (mockup room). The STR Template Library job file is
considered a starting point and variations are likely in each project.

A single mockup room can cater for different types of rooms if the rooms only have minor variations.
Alternatively, you could configure the room and save the job as Room Profile A, then make the
appropriate configuration changes and save the job as Room Profile B, etc.


Before preconfiguring room devices, it is important to identify the installation
capabilities and limitations for each room profile. This ensures that all features and
options work as expected when installed on site.

Configure mockup room job

1. Prepare mockup room.

2. Create mockup room job.

3. Assign channels and devices to areas.

4. Define room logic (features, status, lighting, wake-up, HVAC, UIs,sensors, monitoring).

5. Save configuration to each device in the mockup room (and create Antumbra
multiconfiguration devices).

6. Test each feature and adjust configurations as necessary.

7. Test interoperability.

4.1.1. Project reference tools

• Room layout

• Hardware BOQ

• Hardware single-line drawing

• Circuit allocation table

• Luminaire schedule

• Room profile floor plan

• Electrical drawings with indicative wiring arrangement

• Device Installation Instructions

4.2. Prepare mockup room
The Electrical Contractor installs the devices in each mockup room, including all network, power, and
load connections. Once installed, the System Engineer programs the control features.
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4.2.1. Example Mockup Room

Switched luminaire Occupancy sensor

Dimmed luminaire AntiStumble sensor

GPO HVAC Integration

Curtain control motor Dry contact

Doorbell AntumbraButton

DMX lighting AntumbraDisplay

Example hardware single line drawing

Thermostat Switch Panels
(Entrance, Bathroom,

Bedside Left and Bedside Right)

Occupancy  Sensors  
Bedroom, Bathroom

AntiStumble Sensors  
Bedsides

Input / Output  
Door bell, Corridor  
and Balcony Door

ExpansionRoom Control 
Unit

HVAC
Cont rolle r

4 x High capacity switched  
20A Relay circuits

Hot & Cold Water  
Valve Contro l 
(0-10v)

FCU Control
(High/Medium/Low)

7 x Switched 
lighting circuits

2 x motor control 
circuits

DyNet Room Network

2 x High capacity 
switched circuits

IP Network
(Ethernet )
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Example circuit allocation table

Controller Channel
Number

Description Circuit Label Switched Phase-Cut DMX

General

DDRC-GRMS-
E

R1 Power Sockets GPOs & TV 1    

DDRC-GRMS-
E

R10 Doorbell Chime n/a 1    

Entrance

DDRC-GRMS-
E

R2 Entrance Downlights x2 L1     3

Bathroom

DDRC-GRMS-
E

R3 Bathroom Cove L14 1    

DDMC802 R6 Downlights x2 & Pendant L2, L3, L4   1  

Bedroom

DDRC-GRMS-
E

R4 Bedroom Cove (high) L13 1    

DDMC802 R5 Bedroom Downlight x5 L1   1  

DDRC-GRMS-
E

R7 Bedroom Cove (low) L12     3

DDMC802 R8 Bedside Left Reading L8   1  

DDMC802 R9 Bedside Right Reading L9   1  

DDRC-GRMS-
E

R12, R13 Curtain Power &
Direction

L15 1    

DDMC802 E1 Night Lights L10 1    

DDMC802 E2 Floor Lamp L6 1    

DDMC802 E3 Table Lamp L7 1    

DDRC-GRMS-
E

E4 Wall Sconce x2 L5, L11     2

    Type Count   8 4 11

    Available   4 14 64

    Spare   6 0 53

Example room layout with user interfaces and electrical accessories
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4.2.2. Fixed outputs

Lighting control

A DDRC-GRMS-E load controller has several fixed switched outputs with various relay ratings. It is
recommended to connect the fixed outputs to the following loads:

• GPOs (General Purpose Outlets)

• Switched Room HVAC

• Lighting circuits

• Curtain/blind motors

Please check the capacity of the relay you plan on using to make sure it is fit for purpose. Room status
indicators can be driven by the GRMS digital outputs or a DLLI8I8O. Curtain control channels may also
be used for lighting control as required.

Motor control

For direct motor control, channels are connected to mains. For PLC-based motor control, channels can
be connected to mains, low voltage, or dry contacts. There are two dedicated motor control relay
channels:
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• When selected as a single relay, the output can provide an additional switched lighting circuit.

• When selected for curtain control, outputs are designed to work in pairs and are interlocked in
firmware. First channel energizes/deenergizes the circuit and second channel changes the direction
of travel.

 When wiring, note the location of the Normally Open and Normally Closed terminals.

Modular outputs

As well as controllers with fixed lighting control outputs, multipurpose controllers such as the DDMC802
have modular outputs. Insert the appropriate control modules for the dimmable or switched channels
and connect the outputs to their respective loads:

• Curtain control (interlocked switching)

• Fan control (variable speed switching)

• Relay (switching)

• Driver (ballast) (1-10V/DSI/DALI Broadcast or Addressable dimming, DALI 209 Tunable White)

• Trailing edge (phase-cut dimming)

• Leading edge (phase-cut dimming)


For control modules, you must select the protocol in the Outputs editor > Output
Type.

To configure the modular output channels, install the specified modules and then click the  Query
Modules (or Load from device) to set the corresponding lighting protocols. When loads are connected,
you can test the connections by sending presets 1 and 4 when channels are still unassigned (in Area 1).

4.2.3. Network connections

Dry contact inputs

Connect each volt-free contact to the dry contact inputs. To test that the dry contact input switches are
functioning correctly, close the volt-free contact and check with a multimeter at the controller.

UL924 input

Connect the input switch to the UL924 input. To test that the dry contact input switch is functioning
correctly, close the contact and check with a multimeter at the controller (UL924 settings are located in
Device Properties).

Digital outputs

Connect the outputs to the relevant status indicators. Flash the output channels and check the response
with a multimeter.

DMX

Connect the DMX Tx output to the network connection on the DMX fixtures. On the DDRC-GRMS-E
there are 64 DMX Tx channels. To check the connection, you must have a load connected to the DMX
network and DMX addresses must be within the range of the controller. For more information, refer to
the USITT standard on the DMX512 protocol.
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Ethernet

Connect the Ethernet cable to the DDRC-GRMS-E controller.
From SB, check that you can discover the controller and receive a sign-on message.

DyNet

Connect the DyNet control cable using a daisy chain connection from the DDRC-GRMS-E Room port to
each device in the room.

From SB, connect via Ethernet or RS-485 to the DDRC-GRMS-E and check that you can receive a sign-on
message from the room controller and each room device.

Check network integrity by pressing the buttons on the last UI in the daisy chain to send preset 1 and
preset 4. Note successful device communication by observing the load controller service indicator
flashing rate. New unconfigured sensors respond by blinking faster when receiving an Area 1 message.
If lighting loads are connected, they will turn on and off.

In-room third-party integration

Check third-party integration connections, if applicable:

• AV

• HVAC

• Curtains

• Access control

• Operations/Housekeeping app


For system-level integration to function you must have both System Manager and the
integrated systems installed and configured. Refer to Install System Manager for the
mockup room and Integration.

When designing a room, you must consider power consumption on the control network. If the design
does not include enough controllers, an additional power supply is required to power the sensors and
UIs within the room.

Ensure the network cable current does not exceed 2 amps.

Device Device current @ 12 VDC

DDNP1501 +1500 mA @ 230 V, +1000 mA @ 120 V

PDDEG-S +300 mA

DDRC-GRMS-E +300 mA

DDFCUC +200 mA

DDMC802 +200 mA

DDRC810DT-GL +120 mA

DDRC420FR-GL +120 mA

DDBC120-DALI +120 mA
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Device Device current @ 12 VDC

DDBC320-DALI +300 mA

PDEG/PDEB -100 mA (+200 mA with external supply)

AntumbraDisplay -60 mA

AntumbraTouch -40 mA

AntumbraButton -35 mA

Revolution (PDRxE) -120 mA

DLLI8I8O -30 mA

Multifunction Sensor -10 mA

Ultrasonic Sensor -80 mA

Humidity Sensor -20 mA


Values are subject to change. Please refer to the latest device specification sheets for
current values.

4.2.4. Fan Coil Unit Controller

To control the HVAC, guestrooms are likely to use an integrated HVAC system or a DDFCUC.


For more information, refer to the Fan Coil Unit Controller Commissioning Guide and
DDFCUC Installation Instructions.

The FCUC has the following connections:

• Dry contact inputs (selectable x3):

◦ Airflow sensor

◦ Custom

◦ Dirty air filter

◦ Drip tray overflow

◦ Energy hold-off for window switch
(Not used. Instead, send the balcony door open/close message.)

◦ Hot water on cold valve

◦ Preset

• Input (Dedicated):

◦ Temperature sensor

• Outputs:

◦ Hot valve actuator (open/close)

◦ Cold valve actuator (open/close)

◦ Hot valve actuator (0-10 V)

◦ Cold valve actuator (0-10 V)
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◦ Auxiliary feed through relay output (for electric heat relay)


The FCUC temperature sensor input is not used. Instead, temperature sensing is
achieved through the Antumbra user interfaces. Please refer to Configuring HVAC and
Multi-temperature aggregation.

4.3. Create mockup room job
The STR Template Library SB job file contains the standard configuration and tasking for the different
room controllers and room devices. The System Engineer customizes the library for each specific room
profile to reflect the design of the mockup room. You can place custom tasking in devices other than
the room controller.



The STR GRMS Task can support a single bedroom and bathroom and up to three
HVAC areas natively. The HVAC Object task allows up to 17 additional zones of HVAC
control. To create additional HVAC areas, you will need to change the Area Offset
Multiplier and Box Number Offset Multiplier to a number greater than 20.



For larger suites, more bedrooms are configured by placing an AntiStumble task in a
sensor for additional AntiStumble zones. Other additional zones can be configured by
changing the Area Offset Multiplier and Box Number Offset Multiplier to a number
greater than 20.

4.3.1. Project reference tools

• STR Template Library

• Button text/icon images

• Preset scene definitions

• Integration descriptions

• Mockup room features table

• Room IP address table

• Room mapping table

• Floor gateway IP address table

• Room profile floor plan

4.3.2. Select preconfigured room devices:

1. Open the latest STR Template Library job file.

2. In System View, delete any room devices you do not need.

3. Add more devices to the room controller as required.

◦ To change a device type, select  Change Device Type and select the required device from the
list.

◦ To make a copy of a device, select copy and paste. In the Paste dialog box, select the  Include
Task Data checkbox and click the OK/Yes button.

4. Enter the mockup room job properties.
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5. Click Save As Job File and enter a name for your mockup room job.

4.4. Assign channels and devices to areas
Load controller and device programming follows standard Dynalite programming procedures. The
electrical plan indicates the location and type of electrical services in the room, such as user interfaces,
sensors, power outlets, blinds/curtains, and lights. From the plan, you can then define the location of
logical areas and channels in the room. Interact Hospitality logic relies on assigning circuits and devices
to the standard area numbers as shown in the STR Template Library.

The prebuilt logical offsets in the room controller are defaulted to 20 areas. They are allocated to the
most common requirements for a guestroom. Although you can customize and change these, we
recommend you try to work within this framework to help standardize configuration across projects
and to simplify support requests.

There are also a few areas outside of the standard room range:

• Areas 65000-65005 are used as global areas broadcasting to all rooms.

• Areas in the 200 range are used as room-only messages that do not leave the room.

4.4.1. Assign circuits to an area:

1. In the Areas view Unassigned Devices editor, drag the controller circuits (physical channels) to a
channel in an area or to an area to create a new channel.
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OR

2. In the System view room DDRC-GRMS-E Outputs editor, enter the Logical Area and Logical Channel
number.


This is easier to do in precommissioning, before the DDRC-GRMS-E has a box number
and offsets are in place.


Floor plans are not currently supported in the Multiroom Dashboard but may be used
to assist programming.

4.4.2. Assign devices to an area:

1. In the Areas view, select the  Unassigned Area (A1) Unassigned Devices editor and drag a user
interface, dry contact, or sensor device to an area
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OR

2. Right-click the device and select  Change Area….

 The STR Template Library has devices already assigned to the correct area.


If you intend to use preset scenes, you must have a room controller or expansion
controller with dimming channels.

 Ensure that you have allocated all required channels.

4.4.3. Standard area numbers

Global Areas

Area Channel Preset

 65000 - Day Night Tracking
(System)

 1. Day
 2. Dawn
 3. Dusk
 4. Night
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Room Only Areas

Area Channel Preset

 200 - Wake Up Display Area
(Hidden)

 1. Minute Unit
 2. Minute Tens
 3. Hour
 4. AM PM

Refer to Preset Table in SB

 201 - Dummy Trigger Area
(Hidden)

 1. Initialize devices
 2. Resume Trigger
 3. HVAC Resume Trigger
 4. Suite Wide All Off
 5. Master Toggle 1 Press
 6. Master Toggle 2 Press
 7. Master Toggle 3 Press
 8. Master Toggle 4 Press
 9. Unoccupied Trigger
 10. Goodnight Trigger
 11. Leaving Trigger

 202 - HVAC Events
(HVAC)

 1. Default Guest Settings
Update

 2. Staff Settings Update
 3. Checked Out Unoccupied

Settings Update
 4. Checked In Unoccupied

Settings Update
 5. Green Mode Settings

Update

 1. Guest Preference
 2. Staff
 3. Checked In Unoccupied
 4. Checked Out Unoccupied
 5. Precondition

 217 - HVAC Area 1
(HVAC)

 1. Fan Manual
 2. Fan Auto Occupied
 3. Fan Auto Unoccupied
 4. Off

 218 - HVAC Area 2
(HVAC)

 1. Fan Manual
 2. Fan Auto Occupied
 3. Fan Auto Unoccupied
 4. Off

 219 – HVAC Area 3
(HVAC)

 1. Fan Manual
 2. Fan Auto Occupied
 3. Fan Auto Unoccupied
 4. Off


Areas 65000 - 65005 are reserved for receiving building-wide System Manager
messages.


Areas 200 - 220 are reserved for Room Only Areas. These messages do not leave the
room.

Translated Areas
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Area Channel Preset

 2 - Occupancy
(System)

 1. Guest Occupied
 2. Guest Motion check
 3. Staff Occupied
 4. Staff Motion check
 5. Unoccupied
 6. Recovery
 7. AntiStumble Listen
 8. AntiStumble Room Trigger
 9. AntiStumble Bath Trigger
 10. AntiStumble Room Return

Trigger
 11. AntiStumble Listen Motion

Check
 12. AntiStumble Trigger

Motion Check

 3 - Room
Statuses/Doorbells/Dummy
Channels
(System)

Note: these channels are
mandatory. More channels can
be added as required.

 1. Doorbells
 2. DND Indicator Channels
 3. MUR Indicator Channels
 4. LPU Indicator Channels
 5. Service Indicator Channels
 6. Occupancy Indicators
 7. AntiStumble Mode
 8. Safe Status
 9. GPOs/Plug Loads
 10. Balcony/Window Switches

Primary
 11. Balcony/Window Switches

Secondary
 12. Balcony/Window Switches

Tertiary

 1. On/Closed
 2. On Mode
 3. Auto Mode
 4. Off/Open

 4 – Power Only
(Lighting)

Note: these channels are
suggestions only for controlling
the power to loads based on the
room mode.

 1. Reading Lights
 TV – Example

 1. Checked In/Occupied
 2. Checked In/Unoccupied
 3. Checked Out/Occupied
 4. Checked Out/Unoccupied

 5 - Night Lights
(Lighting)

 1. Bedside Left Nightlight –
Example

 2. Bedside Right Nightlight –
Example

 3. Bathroom Nightlight –
Example

 1. All On
 2. Right On
 3. Left On
 4. Off

 6 - Window Covering 1
Blackouts
(HVAC)

 1. Blackout 1
 2. Blackout 2

 1. Open
 2. Preset 2
 3. Preset 3
 4. Close
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Area Channel Preset

 7 - Window Covering 2
Sheers
(HVAC)

 1. Sheers 1
 2. Sheers 2

 1. Open
 2. Preset 2
 3. Preset 3
 4. Close

 8 - Spare
(Custom)

 1. High
 2. Medium
 3. Low
 4. Off

 9 - Spare
(Lighting)

 1. High
 2. Medium
 3. Low
 4. Off

 10 - Bedroom Lighting
(Lighting)

Note: All channel assignments
are flexible. The library contains
typical assignments only.

Bold = Mandatory Presets

 1. Entry Downlight – Example
 2. Bedroom Downlights –

Example
 3. Bedside Left – Example
 4. Bedside Right – Example
 5. Desk Lamp – Example
 6. Floor Lamp – Example

 1. Bright
 2. Relax
 3. Work
 4. Off
 5. Preset 5
 6. Preset 6
 7. Preset 7
 8. Preset 8
 9. Bright (Night)
 10. Relax (Night)
 11. Work (Night)
 12. Off

 11 - Bathroom Lighting
(Lighting)

Note: Channels can be added as
required.

 1. High
 2. Low
 3. Very low
 4. Off

 12 - Spare
(Lighting)

 1. High
 2. Low
 3. Very low
 4. Off

 13 - Spare
(Lighting)

 1. High
 2. Low
 3. Very low
 4. Off

 14 - Spare
(Lighting)

 1. High
 2. Low
 3. Very low
 4. Off

 15 - Spare
(Lighting)

 1. High
 2. Low
 3. Very low
 4. Off
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Area Channel Preset

 16 – Lighting BLA  1. High
 2. Low
 3. Very low
 4. Off

 17 - HVAC Area 1 Fan Speed
(HVAC)

 1. High
 2. Medium
 3. Low
 4. Auto
 5. Off
 6. 10%
 7. 20%
 8. 30%
 9. 40%
 10. 50%
 11. 60%
 12. 70%
 13. 80%
 14. 90%
 15. 100%

 18 - HVAC Area 2 Fan Speed
(HVAC)

 1. High
 2. Medium
 3. Low
 4. Auto
 5. Off
 6. 10%
 7. 20%
 8. 30%
 9. 40%
 10. 50%
 11. 60%
 12. 70%
 13. 80%
 14. 90%
 15. 100%

 19 – HVAC Area 3 Fan Speed
(HVAC)

 1. High
 2. Medium
 3. Low
 4. Auto
 5. Off
 6. 10%
 7. 20%
 8. 30%
 9. 40%
 10. 50%
 11. 60%
 12. 70%
 13. 80%
 14. 90%
 15. 100%
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4.4.4. Connect System Builder

Connect over Ethernet to a GRMS controller:

1. Connect power to the device(s).

2. Plug the commissioning PC into the Ethernet socket connected to a Gateway, Bridge or Controller
with an Ethernet port (either directly or via a switch).

3. If applicable, configure the router to allow IPv6 multicast addresses.

4. Launch SB and connect using the default IPv6 multicast service address or connect using a TCP IPv4
address.

5. Check that you have selected the correct Interface adapter on your PC and make sure it is on the
same subnet as the gateway.

6. Click OK. You should see the word Connected in the bottom right of the System Builder window.


Devices arrive from the factory with an existing IPv4 address typically based on the
hotel’s IT specification.



For security purposes, the UDP Multicast default service address is being replaced. To
connect to Ethernet devices, click  Insert Devices from Network and select 
Discover Network > Discover Devices over Ethernet. This function finds Ethernet
devices even when SB is disconnected.

Connect over RS-485 to a GRMS controller:

1. Connect power to the device(s)

2. Plug the commissioning PC into a USB PC node, then plug the USB PC node into a DyNet socket that
is connected to the RS-485 network serial port.

3. Launch SB, select the GRMS and connect using a serial connection.

4. Click OK. You should see the word Connected in the bottom right of the System Builder window.
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
Pay attention to whether SB is connected to the room or floor port to ensure you have
the matching connection settings.

4.4.5. Assign mockup room devices

Insert devices from network:

1. Set the DDRC-GRMS-E Room DIP switch to 0 (Zero) and reset the device.

2. In System view, select the top of the tree and click  Insert Devices from Network.

3. Press the service switch on the room controller or search by device code (0x4E). The room controller
now appears in the Discovered Devices list.

4. Click and drag the mockup room controller from the Discovered Devices list onto the room
controller icon. The room controller in the job adopts the box number of the mockup room
controller.

5. Click  Save to Device.

6. Select the room controller.

7. Press the service switch on a room device or search by device code. The room device now appears in
the Discovered Devices list.
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8. If applicable, you can change box numbers for each room device to be in the range 20-39 by
entering the new box number in New Box Number and clicking Change box numbers. The Apply
New Box Numbers window opens and saves the new box numbers to the listed devices.

9. Click and drag the mockup room device from the Discovered Devices list onto the device in System
view. The room device icon adopts the box number of the mockup room device.

10. Close the Insert Devices from Network dialogue box.

11. Click  Save to Device.

12. Repeat steps 6 to 11 for each room device in the mockup room job.

13. Click File > Save as > Save As Job File to save the mockup room job to your PC.

 Third-party sensors are not added to the job as they are included in the tasking.

4.4.6. Configure addressing

Room Address

To allow for the specified number of areas and devices within each room, the Box number multiplier
and Area offset multiplier in the room controller Routing editor are both set to a default value of 20.
Maximum value = 255.

The ID1 DIP switch setting is determined by the total value of all ON switches. The image below shows a
DIP switch setting (1 + 2 + 16) = 19.
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1 2 3 4

ON

OFF

5 6 7 8

1 2 4
8

16
32

64
128

ID1

The ID1 DIP switches on the DDRC-GRMS-E set the room controller’s box number and the offsets for
devices within the room, using the following formulas:

Room controller box number = DIP switch.

Box number range and Area offset range = (DIP switch +1) x multiplier to (DIP switch +2) x
multiplier – 1

For example, If Room 101, has a room controller DIP switch set to 1:

• The room controller box number will be = 1.

• The room device box number range and area range will be
(2 x 20 = 40 to 3 x 20 – 1 = 59) = 40 to 59.

If there is a mixture of rooms with different offsets on a single floor gateway (for example, standard
rooms with 20 areas and suites with 40 areas), then it is recommended to minimize area number
wastage by allocating low DIP switch values to rooms with the larger offset. You then need to leave a
gap in DIP switch values between the larger offset rooms and the smaller offset rooms.

In the example below, DIP switch values 7 to 14 are not used. This enables rooms with a 20-range offset
to start their area numbers exactly where the rooms with a 40-range offset finish.

• used values

• unused values
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DIP switch Floor offset GRMS offset
multiplier

Floor start
area

Floor end
area

Trunk start
area

Trunk end
area

1 1000 40 80 119 1080 1119

2 1000 40 120 159 1120 1159

3 1000 40 160 199 1160 1199

4 1000 40 200 239 1200 1239

5 1000 40 240 279 1240 1279

6 1000 40 280 319 1280 1319

7 1000 20 160 179 1160 1179

8 1000 20 180 199 1180 1199

9 1000 20 200 219 1200 1219

10 1000 20 220 239 1220 1239

11 1000 20 240 259 1240 1259

12 1000 20 260 279 1260 1279

13 1000 20 280 299 1280 1299

14 1000 20 300 319 1300 1319

15 1000 20 320 339 1320 1339

16 1000 20 340 359 1340 1359

17 1000 20 360 379 1360 1379

18 1000 20 380 399 1380 1399

19 1000 20 400 419 1400 1419

20 1000 20 420 439 1420 1439

In the example below, DIP switch values 7 to 10 are not used. This enables rooms with a 20-range offset
to start their area numbers exactly where the rooms with a 30-range offset finish.

• used values

• unused values
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DIP switch Floor offset GRMS offset
multiplier

Floor start
area

Floor end
area

Trunk start
area

Trunk end
area

1 1000 30 60 89 1060 1089

2 1000 30 90 119 1090 1119

3 1000 30 120 149 1120 1149

4 1000 30 150 179 1150 1179

5 1000 30 180 209 1180 1209

6 1000 30 210 239 1210 1239

7 1000 se 20 160 179 1160 1179

8 1000 20 180 199 1180 1199

9 1000 20 200 219 1200 1219

10 1000 20 220 239 1220 1239

11 1000 20 240 259 1240 1259

12 1000 20 260 279 1260 1279

13 1000 20 280 299 1280 1299

14 1000 20 300 319 1300 1319

15 1000 20 320 339 1320 1339

16 1000 20 340 359 1340 1359

Floor Address

Each floor gateway connects via the Ethernet trunk to System Manager and then via an Ethernet spur to
the rooms. Each floor gateway is configured with a unique IP address and offset (physical and logical
address range) for example, 1000, 2000, 3000 etc.

The floor gateway IP address is configured in the DDRC-GRMS-E by adding a Gateway Mapping Port in
the Port Editor. Then, adding a list of all the floor gateway static IP addresses in the Gateway Mapping
editor. One floor gateway can then be selected by the ID2 DIP switches on the DDRC-GRMS-E.


You can enter the Gateway Mapping information in the DDRC-GRMS-E when creating
the hotel job or when the IP address of every floor gateway is known.
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4.5. Define Room Logic
The STR Template Library in the DDRC-GRMS-E contains all the tasking code to facilitate project
programming. Providing a standardized format enables faster installation, commissioning and
deployment, easy upgrades, swift support, and consistent documentation to reduce knowledge burden.

To access the template library, select the DDRC-GRMS-E Tasks tab. You can define the logic in the
mockup room by first entering the task template settings – Activate features, Areas, Task Controls,
Languages, HVAC controls, HVAC Temperatures, Doorbell settings, Automation Settings and Sleep
Settings. Then you can modify the configuration of each feature for your specific project.

These tasks should not be modified

0. Startup Task

1. logical_watcher_task

2. occupancy_area_task

3. status_area_task

4. nightlight_area_task

5. bedroom_lighting_area_task

6. primary_hvac_area_task

7. secondary_hvac_area_task

8. tertiary_hvac_area_task

9. primary_hvac_energy_holdoff_timer

10. secondary_hvac_energy_holdoff_timer

11. tertiary_hvac_energy_holdoff_timer

12. resume_hvac_preset_processing_task

13. vip_refresh_task

14. vip_task

15. greenmode_task

16. day_night_area_task

17. guest_entry_task

18. staff_entry_task

19. resume_task

20. door_close_task

21. doorbell_task

22. unoccupied_timer

23. unoccupied_settings

24. recovery_task

25. check_in_and_out_task

26. access_entry_task

27. dummy_trigger_area_task

28. card_removed_task
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29. goodnight_task

30. dynet_2_watcher_task

31. hvac_event_task

32. bulk_update_bouncer_task

33. humidity polling

34. primary_hvac_humidity_repeat_timer_df

35. secondary_hvac_humidity_repeat_timer_df

36. tertiary_hvac_humidity_repeat_timer_df

37. primary_humidity_reset_task

38. secondary_humidity_reset_task

39. tertiary_humidity_reset_task

40. precondition_timer

41. kit_card_drop_activate

42. kit_mag_or_card_drop_task

43. kit_master_toggle

44. dry_contact_occupancy_refresh_task

45. task_45

These tasks can be modified for each project

46. project_specific_first_day

47. project_specific_first_night

48. project_specific_welcome_day

49. project_specific_welcome_night

50. project_specific_start_up_task

51. project_specific_vip_entry_task

52. project_specific_staff_entry_task

53. project_specific_checked_in_unoccupied_settings_task

54. project_specific_checked_out_unoccupied_settings_task

55. project_specific_check_in_task

56. project_specific_check_out_task

57. project_specific_goodnight_task

58. project_specific_leaving_task

59. project_specific_resume_task

60. project_specific_room_linked_task

61. project_specific_room_unlinked_task

62. task_62

63. task_63

64. task_64
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 The STR GRMS Tasks must be placed in a DDRC-GRMS-E.


Doorbell press should send P2 one touch message which should be excluded for that
channel, doorbell release should send P4 one touch message to the logical channel.

 If Scene Shift is enabled, remember to program presets 8-16 for lighting areas.

4.5.1. Activate Feature

To reduce the number of unnecessary network messages, the library enables you to activate/deactivate
the following features (select True if the feature is used or False if the feature is not used).

Property Description

HVAC Enable if HVAC is controlled. Default = True.

2 HVAC Areas Enable if room has two HVAC areas. Default = False.

3 HVAC Areas Enable if room has three HVAC areas. Default = False.

Window
Coverings

Enable if motorized window coverings are used. Default = True.

Window
Coverings 2

Enable if a second set of motorized window coverings are used. Default = True.

Balcony/Window Enable if Balcony/Window Sensors are used. Default = True.

Night Light
Lighting

Enable if Night light is used. Default = True.

Do Not Disturb Enable if Do Not Disturb (Privacy) is used. Default = True.

DND Indicator Enable if Do Not Disturb (Privacy) indicators are used. Default = True.

Make Up Room Enable if Make Up Room is used. Default = True.

MUR Indicator Enable if Make Up Room indicators are used. Default = True.

Laundry Pick Up Enable if Laundry Pickup is used. Default = False.

LPU Indicator Enable if Laundry Pick Up indicators are used. Default = True.

Service Request Enable if Service Request is used. Default = False.

Service Indicator Enable if Service Request indicators are used. Default = False.

Occupancy
Indicator

Enable if Occupancy Indicators are used. Default = False.

Doorbell Enable if Doorbell is used. Default = True.

Sensors Enable if Sensors are used. Disable if card drop is used. Default = True.

Languages Enable if multiple languages are used in the room. Default = True.

Wake-Up Alarms Enable if alarms are used in the room. Default = False.

Temperature
Aggregation

Enable if temperature aggregation is used in the room. Default = False.
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Property Description

GPO Enable if the GPO/Plug load channel is used. Default = True.

Power Only Enable if the Power Only Area is used. Default = True.

PMS Integration Enable if the system has integration with a property management system. Default
= True.

Scene Shift Enable if you want Area 10 presets to offset by 8 at sunset and sunrise. Default =
False.

Door Mag Switch Enable if you have a door open switch. Default = True.

Access Controls Enable if you have access controls integration. Default = True.

Large Suite Enable if you have more than 3 HVAC zones and need to pass bulk updates to
other devices. Default = False.

Humidity Enable if tracking humidity.

Humidity Refresh Enable if using automatic dehumidification

Precondition Enable precondition room after check in. Preconditioning only runs when the
room is unoccupied and ends when a guest enters the room and does not start
again until after the guest is checked out. Preconditioning pauses if staff enter the
room and resumes when they exit.

Dry Contact
Sensors

Enable if using dry contact sensors on the Motion Control tab of the DDRC-GRMS-
E.


For faster response when changing settings, set Compile Task Template to Manually.
Then when you are finished changing all the settings, click Compile Now.


To make other settings visible, ensure that the matching Activate Feature property is
set to True.


Added support for HVAC objects including area 202 to trigger HVAC events. HVAC
Object task allows for up to 17 zones of HVAC control.

4.5.2. Areas

When assigning channels to areas, the library relies on the following area numbers to be used in the
mockup room. Please request changes by contacting the System Expert team.

Property Description Default Setting

Occupancy Area Dummy Area used for occupancy detection. 2 - Occupancy

Status Area Area of statuses, doorbell. Dummy messages
etc.

3 - Room Statuses/Doorbells/
Dummy Channels

Power Only Area Area of locally switched devices and
appliances.

4 – Power Only

Night Light Area Area of the night lights. 5 - Night Lights

WC1 Blackout Area Area of blackout window coverings. 6 - Window Covering 1 Blackouts
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Property Description Default Setting

WC2 Sheer Area Area of sheer window coverings. 7 - Window Covering 2 Sheers

Spare Area Spare Area. 8 - Spare

Spare Area Spare Area. 9 – Spare

Master Bedroom
Lighting Area

Area of the main bedroom lighting. 10 - Bedroom Lighting

Bathroom Area Area of the main ensuite bathroom lighting. 11 - Bathroom Lighting

Spare Area Spare Area. 12 – Spare

Spare Area Spare Area. 13 – Spare

Spare Area Spare Area. 14 - Spare

Spare Area Spare Area. 15 - Spare

Base Link Area Lighting base link area. 16 - Lighting BLA

1st HVAC Area First HVAC Area 17 - HVAC Area 1 Fan Speed

2nd HVAC Area Second HVAC Area 18 - HVAC Area 2 Fan Speed

3rd HVAC Area Third HVAC Area 19 - HVAC Area 3 Fan Speed

Day/Night Dummy Dummy area used to track sunset and sunrise 65000

Dummy Trigger Area Dummy area used to trigger things in the
room only.

201 – Dummy Trigger Area

Dummy HVAC Event
Area

Dummy area used to trigger HVAC events. 202 - HVAC Events


Areas not in use can be set to Area 1. You can rename areas to suit each specific
mockup room design

 If multiplier = 20, only use area numbers 2 to 19.

4.5.3. Task Controls

The Task Controls section allows you to modify the behavior of each mode.

Property Description

Scene Shift Update Controls if scene shifted areas are preset reset on sunrise and sunset to update
levels to new value with a 20-minute fade time.

Debug Mode Debug mode sends a debug message any time a task is triggered.
True/False

Lang1 on Start up Enable if language 1 home page is desired on startup. Disable if options page is
desired on startup.
True/False
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Property Description

Unoccupied
Setting Delay

Delay time after the HVAC turns off before the curtains close and lighting turns
off when a room becomes unoccupied.
Maximum valid value: 21:50:000 (rounded to 10 ms).

Entry Delay Select how long to queue an access control entry message before assuming
someone swiped without entering.
Maximum valid value = 21:50.000 (minutes:seconds.milliseconds rounded to
10ms).

Late Entry Msg
Delay

Select how long to wait after a door open for a late access control entry message
to show up before marking the room as guest occupied.
Maximum valid value = 21:50.000 (minutes:seconds.milliseconds rounded to
10ms).

4.5.4. Languages

The Languages section enables you to enter two bytes in hexadecimal to set the default language:

• Language 1 High (Hex): First byte of the default language.

• Language 1 Low (Hex): Second byte of the default language.

Language: "Language Code(High Byte,Low Byte)"

• Arabic: AR(41,52)

• Dutch: NL(4E,4C)

• English: EN(45,4E)

• French: FR(46,52)

• German: DE(44,45)

• Italian: IT(49,54)

• Japanese: JA(4A,41)

• Mandarin: ZH(5A,48)

• Spanish: ES(45,53)

• Thai: TH(54,48)

• Vietnamese: VI(56,49)

4.5.5. HVAC controls

The HVAC Controls sections provides HVAC setup data.

Property Description

HVAC Off Delay Delay time after the balcony door or window is opened before HVAC turns off.
Maximum valid value = 21:50.000 (minutes:seconds.milliseconds rounded to
10ms)

HVAC On Delay Delay time after the balcony door or window is closed before HVAC turns back on.
Maximum valid value = 21:50.000 (minutes:seconds.milliseconds rounded to
10ms)
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Property Description

Set Temp Override Determines if set temperatures get overridden on occupancy changes and then
resumed on guest entry. False would rely on deadbands shifting on occupancy
changes.
True/False

Relative Set Temp Determines if set temperatures are offset relative to guest preference when
unoccupied. False would send a specific set temperature based on bulk variable
updates.
True/False

Relative Set Temp
Offset

Number of degrees Celsius (°C) that the set temperature is increased when room
becomes unoccupied.

Max Set Temp
Offset

Maximum allowed set temperature in degrees Celsius (°C) that the set
temperature can be increased to when room becomes unoccupied.

HVAC Temperature Conversion

Celsius 17°C 18°C 19°C 20°C 21°C 22°C 23°C 24°C

Farenheit 62°F 64°F 66°F 68°F 70°F 72°F 73°F 75°F

4.5.6. Humidity Settings

This section controls dehumidification behaviour.

Property Description

Dehumidification
Fan Speed

Fan speed during humidity refresh.

Dehumidification
Set Temperature

Target Set Temp during humidity refresh.

Dehumidification
Start

Refresh will begin when humidity exceeds this value.

Dehumidification
End

Refresh will end when humidity drops below this value.

Dehumidification
Minimum
Temperature

The minimum temperature for dehumidification. Below this value
dehumidification is impractical.

Dehumidification
Max Duration

Maximum duration of a humidity refresh in minutes. Max 255.

Dehumidification
Repeat Delay

Time between dehumidification attempts in minutes. Max 255.

Humidity Polling Enable if humidity sensor requires polling.

Humidity Polling
Interval

Interval between humidity polling.
Maximum valid value: 21:50.000 (rounded to: 10 ms).
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4.5.7. Doorbell Settings

The Doorbell section allows you to modify the behavior of the doorbell.

Property Description

DND Doorbell
Mode

Controls whether doorbell is disabled by DND mode.
True, False.

Doorbell Limits Enable if Doorbell is limited to prevent excessive pressing.
True, False.

Doorbell Max Ring Select max time the doorbell can ring on a single push.
Maximum valid value: 21:50:000 (rounded to 10 ms).

Doorbell Delay Select how long the doorbell is disabled after pushing.
Maximum valid value: 21:50:000 (rounded to 10 ms).

4.5.8. Card Drop Settings

If used, this section controls the card drop delay.

Property Description

Card Drop Delay Select how long after the card is removed before the room becomes unoccupied.
Maximum valid value: 21:50:000 (rounded to 10 ms).

4.5.9. Sensor Controls

If used, this section sets the occupancy timeout delay.

Property Description

Sensor Timeout
Delay

Delay time to wait for the sensor to timeout. Must be longer than the sensor’s
internal timeout.
Maximum valid value: 21:50:000 (rounded to 10 ms).

4.5.10. Automation settings

Automation controls the interaction between different features.

Property Description

DND LPU Mode Enable if LPU is disabled by DND mode.
True/False

DND Service Mode Enable if Service Pickup is disabled by DND mode.
True/False

DND Deadbolt
Mode

Enable if DND is turned on when deadbolt is thrown and off when released.
True/False

4.5.11. Sleep Settings

The Sleep Settings section allows you to modify the Sleep Mode behavior when the Goodnight task is
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triggered.

Property Description

Night Light Mode Default Nightlight Mode when goodnight task is triggered.
0=Off, 1=On, 2=AntiStumble

Sleep Status Mode Controls if DND is set by goodnight task.
True/False

AntiStumble/Time
of Day Mode

Controls if AntiStumble is halted at sunrise.
True/False

4.6. Configuring Room Status

4.6.1. Occupancy

Real-time occupancy is detected by the room sensors. Front door opening/closing triggers the
occupancy detection task to update the Area 2 - Occupancy preset. This is combined with the Checked-
In/Out status to determine if it is a guest or staff in the room and whether it is daytime or nighttime.


For projects without access control integration, any checked-out entry is treated as
staff-occupied and any checked-in entry is treated as guest-occupied.


Although key drop occupancy detection is offered it is not recommended as it is easily
overridden by the guest.

4.6.2. Room states and modes

The system uses context from the real-time clock, room sensors, PMS, and Multiroom Dashboard to
switch between room states and modes:

• Checked-Out & Unoccupied state

• Checked-Out & Occupied state

• Staff Mode

• Checked-In & Unoccupied state

• Checked-In & Occupied state

• Welcome

• Daytime

• Evening

• Green mode

• VIP mode

• Guest preferences


Green Mode and VIP Mode are mutually exclusive. Selecting one automatically
deactivates the other.
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4.6.3. Guest services

Guest service requests are indicated by the room status. Area 3 channels are used for room status
indicators and non-lighting features. The associated task for Area 3 detects the DND/MUR/LPU/RSP
status, the doorbell status, and the balcony door status.

4.6.4. Power outlet control by room state

The power outlets (GPOs/plug loads) and other switched appliances in the room are automatically
energized based on guest occupancy and the checked-in/out state. Some non-controlled power outlets
may be designated in the room to provide power continuity for AV equipment, computer charging,
minibar, etc. These channels should be assigned to Area 4.

4.7. Configuring Lighting

4.7.1. Switching

Switching is the simplest method of lighting control. In the controller, this functionality is performed by
relays. All output channels can be configured for switching only, if required. The electrical design should
ensure that the number and types of loads in each switched circuit do not exceed each output’s power
rating.

When grouped into logical areas, combinations of lights can be switched simultaneously to create
different lighting scenes.



DDRC-GRMS-E Outputs:

• Channels 1-13: Switched

• Channels 14-17: Digital

• Channels 18-81: DMX Tx

DDRC-GRMS-E output channel 1 should be used to switch the general purpose outlet’s circuit in the
room.

DDRC-GRMS-E output channels 10 to 13 are designed for switching two curtain motors. DDRC-GRMS-E
channels 10 and 12 control power to the motors and DDRC-GRMS-E channels 11a, 11b, 13a and 13b
toggle the motor direction. The firmware ensures that the motor direction relay only changes state
when the power channels are switched OFF. The room control task uses preset messages to area 6 for
curtain control (Preset 1 = Open, Preset 4 = Close, Stop Ramp = Stop).

More complex switching combinations and sequences can be created in the user interface Action Chain
Editor or in the Task Editor.

 For switching channels, fade times should be set to 0 (Zero).


The addition of a DDNG485 enables direct control of Somfy controllers and blind
motors in the room. For more information, refer to the DyNet to Somfy Commissioning
Guide.
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4.7.2. Preset Scenes

Scenes are created in the Preset editor for each area in the guestroom. Where provided by the
controller, the Preset editor allows the lighting intensity and colors to be defined for each logical
channel in a preset.

Specific channels can be excluded from a preset or set to switching only in the Outputs editor.

Project Reference Tools

• Preset table

Example preset table

Interact Hospitality default scenes are Bright, Relax, Work, Bedside Off, and Entry Off. Presets are offset
by 8 at sunset and returned to normal at sunrise.

Other scenes can be prepared to suit the exact requirements of the lighting designer. For example:

• Welcome scene - light intensity based on time of day with curtains open and the TV showing a
welcome message can help new guests explore their room.

• Turndown scene - In the evening after turndown, the room can be dimmed with a soft focus on the
bed and pillow gifts (Turndown scene can only be activated by staff)

• TV/Movie scene - A guest can choose a scene tailored for enjoying TV and films with softer lighting
and no glare, such as bedside or table lamps only.

• Reading scene - For guests wanting to sit in the reading chair or for brighter task lighting on the
desk.

Scenes can also be dynamic, taking into account natural daylight or time of day, in achieving your
intended effect. Rather than having multiple buttons for the same area to recall different lighting
scenes – for example in the bedroom, Morning, Afternoon, Evening and Night scenes can be recalled by
a single button on a user interface programmed so that the right scene is recalled for that specific time
of day. This allows for a simplified experience with fewer buttons required. Examples of this logic can
also be found in bathrooms to allow a softer light level upon entry during the night, instead of
traditional controls which would just turn the lighting on to 100%. The options of adaptive
configurations are only limited by the imagination.

Colorful scenes

Tunable white and color control can be offered with DALI luminaires or DMX luminaires. DMX offers full
color control using Red, Green, and Blue channels. The DDRC-GRMS-E can control up to 64 DMX
channels.
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

Suggested color temperatures for tunable white scenes:

• Relax = 2200k

• Work = 3500k

• Bright Day = 3000k,

• Bright Night = 2700k

Tunable white offers additional vitality scenes. The following four scenes use (proprietary) scientifically
tested combinations of color temperature and lighting intensity:

• Standard - Cooler tones at higher intensities for more functional activities.

• Creativity - Warm, dimmed lighting supports creativity and cooperation.

• Focus - Bright light supports focus and concentration.

• Presentation - Warmer tones at lower intensities for more emotional activities.

4.8. Configuring HVAC
HVAC control has the potential for the most energy savings in the room. In some climates, HVAC can
consume as much as 60% of the energy in guestrooms. Integrating control of this service is therefore a
significant opportunity to drive efficiency.

Every Antumbra user interface includes a temperature sensor, allowing you to choose the most
representative location from which to measure current temperature and trigger heating or cooling. This
could be time based - measuring from the entrance in the daytime and switching to readings from the
bedside overnight to most accurately reflect guest behaviors. Alternatively, you can choose average
readings from different groups of sensors (multi-temperature aggregation) for an accurate overall
representation of the guestroom.


Additionally, the humidity sensor is regularly polled by a task in the room controller to
display the value on the dashboard.

Guests are offered manual control of HVAC features such as fan speed and setpoint (only setpoint is
shown, not current temperature). HVAC can be automatically shut down or set to a different setpoint
when the room is checked-in/out and/or occupied/unoccupied.
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Summer Winter * Average set points as published online, October 2016

Cool to 23°C

Heat t o 20°C 

Cool to 21°C

Heat t o 18°C 

Year round,
cool to 24°C 

Cool to 25°C

Heat t o 19°C 

Cool to 28°C

Heat t o 20°C 

Across the world different regions cool and heat their spaces to seasonal setpoints, nominally set as
summer minimum and winter maximum levels. The global areas in the system are used to communicate
day/night and seasonal changes.

Research suggests that for every 1°C reduction in heating/cooling, up to 10% energy savings can be
achieved. To help you achieve this, HVAC integration enables you to present your guests with the choice
to activate Green Mode as part of your brand’s sustainability messaging.

Options:

• Switch to Green Mode through a simple leaf icon on the AntumbraDisplay. This activates a wider
setpoint tolerance of 2-3°C (or your choice of setpoint) to save energy and allow guests to engage
with making a difference in energy consumption.

• Not take part, and instead set their temperature preferences which the system maintains (default).


For more information, refer to the Fan Coil Unit Controller Commissioning Guide. For
system-level HVAC integration, refer to CoolAutomation Integration.

4.8.1. Multi-temperature aggregation

By reading a combination of different temperature sensors at different times of the day, multi-
temperature aggregation provides a more meaningful temperature for an area, considering
temperature gradients and intended usage.

The DDRC-GRMS-E polls individual sensors using DyNet2 physical messages for their actual temperature
reading. These values are assigned a configurable weight% then averaged to create the aggregated
temperature value. Then an aggregated temperature message can be sent from the HVAC area.

A logical message to change the active mode determines which group of sensors to read. For example,
1C,02,24,48,00,01,FF (Active mode 1), 1C,02,24,48,00,02,FF (Active mode 2).

There are typically two active modes:

• Daytime - The average of temperatures from multiple sensor readings is made and provided to the
room network for the HVAC controller (e.g. FCUC/CoolMaster/BACnet) to use for heating/ cooling.
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This enables a truly representative room temperature enhancing energy efficiency (not over
heating/cooling) and maximizing guest comfort.

• Overnight - Only selected (bedside left and right) sensor readings are taken to represent the guest’s
location in the space, further enhancing guest comfort.

Configure multi-temperature aggregation

1. Select the room controller.

2. Add the Antumbra panels to the room controller.

3. Click the Temperature tab.

4. Set the applicable properties. Refer to the Temperature editor properties table below.

5. Click  Add Group.

6. Enter a Name for the temperature group.

7. Enter the group’s Active mode number.

8. Select a Logical area, Join, and BLA, if applicable. The logical area is set to the default HVAC area 17.
This is the area that sends the aggregated temperature message to the trunk network. The BLA is set
to default dummy HVAC area 217 (This area does not need to exist in the project and is used only
within the room by the DDRC-GRMS-E and FCUC tasking).

9. Click  Add Sensor for each Antumbra that you want in the temperature group (up to eight).

10. Enter the Antumbra Box number.

11. Enter the Antumbra temperature reading Weight % (total must add up to 100%).

Temperature editor properties

General
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Property Description

Control Enabled or disabled. Used to enable/disable the multi-temperature
aggregation feature.

Broadcast temperature

Property Description

Broadcast temperature Enabled or disabled. When enabled, sends the aggregated temperature
message.

Delta value (°C) The minimum temperature change required to trigger an aggregated
temperature message.

Min trigger time The minimum time that must elapse to trigger an aggregated temperature
message.

Max trigger time The maximum time to trigger an aggregated temperature message.

Sensor Polling

Property Description

Polling loop interval The time between requests to read all temperature sensors.

Polling message send
delay (milliseconds)

Delay between sending requests to each temperature sensor.

Temperature group properties

General

Property Description

Temperature group Enabled or disabled. Used to enable/disable the temperature group.

Name Temperature group name.

Active mode Index number to set the active temperature group. This is sent via a DyNet1
User Preference message. Up to 16 temperature groups are supported.

Logical Address

Property Description

Logical Area Enabled or disabled.

Join The static join of the device.

BLA Base Link Area. A dummy HVAC area. Messages to this area stay within the
room and are not sent to the trunk.


For consistency of operation, you should still use the temperature aggregation feature
even if you are only taking readings from a single sensor.
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
If not using temperature aggregation at least one Antumbra should be configured to
broadcast temperature to the HVAC area. (17, 18, or 19).

4.8.2. HVAC for large suites

The DDRC-GRMS-E tasking template library provides for up to three HVAC areas (17, 18, 19). A
thermostat (AntumbraDisplay) is required in each area to measure the actual temperature and allow the
user to adjust the setpoint.

In the library there is also an HVAC task placed in the DDFCUC (or Antumbra UI if not using the DDFCUC
for HVAC) to enable additional HVAC areas for large suites and public spaces. A copy of the HVAC task is
required for each additional HVAC area.

Configure an additional HVAC area:

1. In DDRC-GRMS-E > Tasks > Activate Feature settings, set the Large Suite property to True.

2. If required, in the Routing editor enter a number (larger than 20) in the Area offset multiplier and
the Box number multiplier properties to cater for the additional HVAC areas.

3. In the Areas tree, copy and paste one of the HVAC areas to create an additional HVAC area. For
example, area 20, 21, 22, 23, etc. If using a DDFCUC in the room, you also need to copy and paste
one of the Room Only HVAC areas to create an additional matching FCUC HVAC area in the 200
range, e.g. 220, 221, 222, 223, etc.

4. In area 3, create an additional logical channel for each HVAC area that has a Balcony/Window
switch. This enables the Energy Holdoff signal to turn the air conditioning on and off (according to
the HVAC Off Delay and HVAC On Delay) when the balcony door/window is opened/closed.

5. In DDFCUC > Tasks > Activate Feature settings, set HVAC Object, FCUC Conversion, and
Balcony/Window (if applicable) to True.

6. In DDFCUC > Tasks > Task Controls settings, enter a unique Offset Delay and Message Delay so
responses to HVAC events in different areas do not all happen at the same time (to reduce network
burden).

7. In DDFCUC > Tasks > Areas settings, click the GRMS Template HVAC Area > Change button and
select the new HVAC area number. Also, click the FCUC HVAC Area > Change button and select the
new matching area number from the 200 range.

8. Configure the HVAC Controls properties, including the Balcony channel number if applicable.

9. Click  Save to Device.


In the Room Mapping table, ensure that the Room Area Offset has a large enough
range to allow for additional HVAC areas.


If using VRF/Split Units or another HVAC system (not the DDFCUC) then add a DACM
with the HVAC task to your job.

4.9. Configuring network user interfaces
Controlling the lighting in the room, by switching, dimming, or adjusting the color of areas and
channels, is the key to helping guests feel comfortable during their stay.

Rather than large banks of switches and confusing settings, the system can present your guests with
intuitive, logical groupings of buttons with appropriate names and/or icons. Simplifying usage to an
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effortless button press encourages adoption and use of the system by people regardless of their
technological comfort level.

Using a network user interface allows the user to interact with the system more intuitively to control
different system functions. The built-in button indicators or display can give the user feedback on the
current system status.

Inputs from network user interfaces are triggered by a button press from the user. The inputs are
configured in the Buttons Editor for each user interface. Additionally, the AntumbraDisplay Display
and Buttons Editor allows you to select icons and text for room information and functions on the
display.

For room status indicators, instead of using lighting channels you can use a network user interface or
third-party panel outside of the room to indicate Do Not Disturb/Make Up Room/Laundry Pick
Up/Service Pickup.

This user interface may also include a doorbell function that can flash the lights or ring the doorbell
when paired with a third-party door chime. Indicators can be set/cleared from the main button user
interface inside the room and/or from an integrated room booking system.

Network user interfaces may include AntumbraButton, AntumbraTouch, AntumbraDisplay, or
Revolution.

 On each panel, the location of the Goodnight button should be closest to the bed.

Example Antumbra Layouts

4.9.1. Room status buttons

Room status information is controlled by the Room Status function. This is displayed on the dashboard
and sent to the property management system (PMS). These functions can be assigned to the dry contact
input switches on the DDRC-GRMS-E or DLLI8I8O, or to any button on an Antumbra interface.


These functions are already programmed in the STR Template Library to control room
status information.
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Room Status Function

The Toggle room status sub function uses a single button to turn a status on and off. Click the Status
Type dropdown list to select a status.

The Set room status sub function uses a single button to set a status value on (Set) or off (Reset). Click
the Status Type dropdown list to select a status.

The Status value for sub functions Keycard Inserted (occupied) and Keycard Removed (unoccupied) is
Set.

The Status values for the sub function Room Status are:

4.9.2. Antumbra preconfigurations

The Dynalite Application Communication Module (DACM) can store multiple configurations in a single
unit.
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The installer can then select a configuration by setting the DIP switches on the DACM, with no further
commissioning. This allows all Antumbras to perform the functions of the other Antumbras in the room
based on the DIP switch setting, for example, Entry, Bathroom, Bedside left, Bedside right, Living Room,
Desk, etc.



The number of configurations is limited by the EEPROM size. AntumbraDisplay
consumes more space due to graphical elements. Ideally all configurations would be
on a single DACM, but you can split the multiconfigurations for your project across
two or more DACMs if required.

Create a new multi-configuration device:

1. Starting with an SB job containing all the required Antumbra configurations, either:

a. Click  Insert Device from List (or Ctrl  +  D ) to create an Antumbra Multi-Configuration
device.

b. Right-click and  Factory Set a compatible Antumbra device on the network to Multi-
Configuration.

2. In the Multi-Configuration Editor tab, use the  Add button to add any of the Antumbra devices
in the job.

3. Set the required properties for each of the devices.
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4. Click  Save To Device to save to the Multi-Configuration device.
Note that if the DIP switches on the device are set to the value of any of your configurations, the
device will restart with that configuration immediately after saving.

Antumbra Multi-Configuration Properties

Property Description

Name This is the name of the configuration. It defaults to the same name as the
original device in the job, but it can be changed.

DIP switch This sets the DIP switch value (0 – 63) for the selected configuration. It’s
recommended not to use 0, and to set the DIP switches on the actual device
to 0 while commissioning.

You can choose DIP switch values that are easy to set onsite. For example, if
you have 6 configurations, you can use 0x01, 0x02, 0x04, 0x08, 0x10 and
0x20. This allows recall of each configuration by switching a single DIP switch
bit to the ON position.

Box number This is the spur box number that the device will have when the configuration
is recalled. It defaults to the same box number as the original device in the
job, but it can be changed. Note that you can create multiple configurations
with the same box number. In the picture below there are 2 devices called
Antumbra Kitchen with box number 84. This may be useful for quick
configuration changes onsite.

Enabled True or False

Synchronizing configuration updates from original devices

Click the  Rebuild from Devices in Job button to synchronize the current settings of all the original
devices in the job to the Multi-Configuration device.

Loading a multi-configuration device from the network or from a hex file

If a multi-configuration device must be loaded from the network or from a hex file, the original devices
will not be known. In this case the configurations each appear with a  icon beside them. The Original
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Device in Job > Name field will also be empty.

For devices in this state it is possible to change the name, DIP switch, and Enabled settings, but not
possible to change the box number.

To change the box number or any other device configuration, selectthe config you wish to edit then use
the  Recreate Device in Job. The image below shows a recreated device. Note that devices are
recreated in the job without a box number.

Now that the Antumbra Hall device exists in the job, you can change its configuration and then sync it
back to the Multi-Configuration device using  Rebuild from Devices in Job.

4.10. Configuring third-party user interfaces

4.10.1. Dry Contact Inputs

In addition to a network sensor or user interface, room functions can also be triggered either from an
AntumbraLite button panel or a third-party interface (such as a button panel or a window/door reed
switch.)

Inputs are provided by a dry contact input on a network device such as the DDRC-GRMS-E controller or a
DLLI8I8O dry contact interface device. This allows the control system to detect button presses or door
open/close state. Dry contact inputs also enable the use of custom manufactured user interface panels
that match the project’s design requirements.

A third-party interface may be one of the following:

• A user interface button with or without LED indicators.

• An output from another system.

• An open/close switch on a keycard holder, window, or door.



Additionally, you can configure the DDRC-GRMS-E UL924 input to trigger an
emergency preset via the Device Properties Editor.

UL924 input is different to a DyNet panic message. There is no network message, and
it is not reversible via DyNet packets.
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4.10.2. Card Drop Integration

Configure occupancy based on card drop (sensor-based occupancy detection is recommended):

1. In System view, select the DDRC-GRMS-E and open the Tasks tab.

2. Click  Edit to open the Tasks Editor.

3. Click the Persistent Memory tab.

4. Set persistent memory index 10 $Card_Drop to 01.

5. Close the Task Editor and click Yes to save changes to the job file.

6. Select the Switches tab

7. Configure Dry Contact 8 (Card Drop) to send the Set room status - Keycard Inserted/Removed
messages. When the card is removed the system marks the room as unoccupied and disables all
keypads and dry contacts until reinserted.

8. Click  Save to Device.

9. Click File >  Save to save the job.

4.10.3. DLLI8I8O Dry Contact Inputs

A DLLI8I8O dry contact interface with LED indicators for each button gives the user feedback on the
current system status. The indicators can show which button has been pressed or which mode is
selected. The inputs are configured in the Switches Editor for the device.

Buttons connected to panels can perform identical functions by configuring the inputs accordingly, or
by wiring the inputs in parallel.

4.10.4. Other Third-Party Inputs

Other third-party devices with RS-232 or RS-485 ports connect to the control network via an integration
device. This method is commonly used for:

• AV systems with built-in DyNet compatibility, such as AMX and Crestron.

• Third-party control of the lighting system.

• Lighting system status feedback to a third-party system.

• Notification of alarm conditions, such as circuit breaker trips and smoke or gas detection.
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4.11. Configuring Third-Party Sensors
DDRC-GRMS-E dry contact inputs 1 to 4 can be connected to a third-party sensor for occupancy control.
Occupancy is checked 30 seconds after the magnetic switch input detects that the front door has been
opened and closed.

Configure third-party sensor:

1. In System View, select the DDRC-GRMS-E Tasks tab.

2. Set Activate Feature > Dry Contact Sensors to True.

3. Set the Sensor Controls > Sensor Timeout Delay to the required timeout period. The delay must be
longer than the sensor’s internal timeout period.

4. Open the Switches tab and configure one of the first four switches to Logical Area: 2, Function:
Motion Control.

5. Open the Motion Control tab and tick the Enable Motion Control checkbox for the respective input
(1 to 4) connected to the third-party sensor. There is no need to change the motion control
properties as they are already configured by the task template.

6. Click  Save to Device.

7. Click  File Save to save the job.

4.12. Configuring Wake-Up
The Wake-Up feature mimics sunrise by simulating the dawn light before a set wake time. Wake-up
lighting can reduce sleep inertia and improve well-being.

Wake-Up is configured using a combination of devices and software:

• AntumbraDisplay (contains the wake-up tasking)

• Multiroom Dashboard

• PMS (optional)

• Ethernet gateway (if using Day Rhythm feature)

• Controller with dimmable and color control outputs
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• Tunable white drivers and lamps


If wake-up is used, the Activate Feature section of the DDRC-GRMS-E STR Template
Library must be set to True so that the alarms get cleared on check-out.

The wake-up alarm can be set from the AntumbraDisplay, the Dashboard, or the PMS. The alarm time is
saved in the AntumbraDisplay, which shows the alarm time and listens for time messages from the real-
time clock in the PDEG/PDDEG-S.

Depending on the specific configuration, sometime before the alarm triggers (default = 20 minutes), a
task typically recalls a sequence of presets for both the main lighting area (10) and the spare colored
lighting area (12). It also changes the page on the AntumbraDisplay to the snooze page where the
guest can choose to:

• Let the sequence continue

• Turn it off and turn the lights on to bright

• Turn it off and turn the lights off

• Snooze for 9 minutes, turning the lights off.
After the snooze period expires, a truncated sequence resumes.

The task must be on the AntumbraDisplay, and requires area 200 for the display and wake-up opcodes
for area 3 for the actual commands to communicate with the STR Template Library tasks in the DDRC-
GRMS-E.

Home No Alarm 12 Hour Wake Alarm

Home Alarm Set 12 Hour Wake Snooze

If applicable, all actions can be saved and synchronized with the PMS - refer to PMS integration.

4.13. Configuring sensors
Accurate guest detection is key to allowing the status and condition of the room to be automatically
updated, whether for guest comfort or operational efficiency. Through a combination of sensor
hardware, integration design and contextual logic we can determine whether a room is occupied,
whether they are a guest or staff, the natural light level, the current temperature, window/door status,
etc.
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This detection can recall either a welcome scene or intelligently remember the previous scene and revert
to the guest’s preferences. Combined with access control, the room services can react differently to staff
occupancy compared to guest occupancy.

In unoccupied states, such as during breakfast or in the daytime, the room can step down services over a
period of time. Cutting all HVAC for example can maximize energy savings, while stepping to a 3-4°C
difference allows the room to revert to its previous state more quickly than when HVAC is turned off.

There are three categories of guestroom sensors:

1. Bedroom sensors - detect where people sleep.

2. AntiStumble sensors - detect feet when they leave or enter the bed.

3. Bathroom sensors - detect anything else (bathroom, balcony, entry, closet, living room, etc.).

4.13.1. Bedroom sensors

Motion control detection in the bedroom sensor triggers preset scenes in the Occupancy area.

The Occupancy Area task in the STR Template Library then uses this input to update the occupancy
status of the room.

4.13.2. AntiStumble sensors

AntiStumble sensors are placed under the bedside tables. They recall a low light level in bedside and
bathroom lights to help guests navigate to the bathroom at night. The sensors are configured to detect
motion only when the room is in the Goodnight preset or when the light level is below a certain value.

Nightlights can be specified in the bedroom and bathroom to use movement detection from the
bedside (wall) sensors and bathroom (ceiling) sensors whenever the Goodnight preset is active.

The sensor timeouts should allow sufficient time to navigate from the bedside sensor detection zone to
the bathroom sensor detection zone. When a guest returns to bed, the nightlights automatically switch
off, based on the timeout since last movement was detected (default timeout = 30 seconds after leaving
the bed and 3 seconds after returning to bed).
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4.13.3. Bathroom sensors

Bathroom (or balcony, entry, closet, living room) sensors signal occupancy in the Occupancy area. They
can also recall presets in a specific area.


If a portable cot or pull-out sofa is likely to be used in an area, then configure the
sensor as a bedroom sensor.

4.14. Configuring room monitoring
Room monitoring can be performed by the corridor panel and/or the room monitoring software.

Corridor Panel

• The corridor indicator panel outside of the room can signal the DND/MUR/LPU/RSP or occupancy
status of the guestroom to hotel staff.

• The DND/MUR/LPU/RSP function requires a DLLI8I8O or room controller digital output to drive the
indicators and a button panel within the room for the guest to set their room status preference.

Monitoring software

Networked rooms provide many benefits including automatic reporting of the room status to the
central System Manager Server. When rooms are monitored, additional system messages are also
captured, such as preset state, channel levels, and DND/MUR/LPU/RSP status.

With the Multiroom Dashboard installed, operational staff can monitor the status of all guestrooms and
are automatically informed if the system detects a fault within the network. If DALI Addressable fittings
are used, then driver and lamp failure detection is also possible. System Manager seamlessly integrates
with many different systems, with the Hotel Integration API enabling a wide variety of applications.
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Dashboard floor view

Save configuration to each device

Before testing each feature, save the configuration to each device in your mockup room:

1. Select each device in the job.

2. Click  Save to Device.

3. Click  File Save to save the job.

4.15. Mockup room testing
Perform scenario-based testing to confirm that all room controls are functioning according to the
System Control Requirements.

4.15.1. Example System Control Requirements

1. Ability to control all lights in Guestroom.

2. Ability to control A/C set point temperature through a fully modulating valve.

3. Ability to control A/C Fan Coil Unit fan speed.

4. Ability to control power supply to TV.

5. Ability to control motorized curtains.

6. Ability to differentiate between guest key opening door and staff key opening door.

7. Ability to change timings as to when system takes control after guest leaves room (during the guest
stay or upon checkout).

8. Ability for system to detect presence in the room, method of detection to be advised (sensor, key
drop).

9. Ability to generate energy usage reports and view on lighting dashboard.
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10. System must be able to determine the difference between a guest or employee entering the room
to determine access to equipment.

11. System must allow an administrator to adjust/customize settings if local environmental conditions
demand.

12. Equipment always powered on:

a. Mini Bar

b. Electrical outlet at desk

c. Electrical outlet in guest safe

d. Universal power sockets

e. USB Chargers

4.15.2. Example Scenario 1 – Room unoccupied

a. Dependent on the ambient temperature the system will hold the room at a predetermined
temperature, this temperature should be adjustable by the system administrator.

b. FCU fan speed will be controlled to maintain predetermined temperature.

c. All lights in bedroom and bathroom will be off.

d. If there are motorized curtains, then the curtains will be closed to minimize solar gain.

e. Power to TV will be turned off.

4.15.3. Example Scenario 2 – Room unoccupied – employee enters room

a. System to identify that it is an employee in the room via occupancy sensor and access control system.

b. System to maintain control of A/C and predetermined temperature.

c. All lights to be powered for staff member to check they are working.

d. TV to be powered to all staff members to check signal.

e. Curtains to open.

f. System to take control of room after 5 minutes (based on operational needs) after the staff member
leaves the room and return room to unoccupied status and predetermined settings.

4.15.4. Example Scenario 3 – Room unoccupied then guest checks in (Checked-in,
Occupied)

a. When a check-in event is received the room state changes from Checked Out, Unoccupied to
Checked In, Unoccupied and some settings change like GPO on, Temp Setpoint change.

b. When a guest enters the room the room state changes to Checked In, Occupied mode that changes
more settings including lights, curtains and temp setpoint (day/night dependent).

c. When the guest opens the door for the first time, the room should go into a welcome scene, this
welcome scene should include specific lights.

d. System signals the controls to adjust the A/C to 23°C (based on operations requirement).

e. System signals the controls to switch on TV.

f. Systems signals the control to open the curtains during daytime or close them in the evening unless
we want to highlight the view.
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4.15.5. Example Scenario 4 – Guest is checked into room but leaves the room

a. Room goes to Vacant state 15 minutes (based on operations requirement) after the guest leaves the
room.

b. Dependent on the ambient temperature the system will raise the room to a predetermined
temperature, this temperature should be adjustable by the system administrator.

c. FCU fan speed will be controlled to maintain predetermined temperature.

d. All lights in bedroom and bathroom will be off.

e. If there are motorized curtains, then the curtains will be closed to minimize solar gain.

f. Power to TV will be turned off.

4.15.6. Example Scenario 5 – Guest is checked into room but leaves the room
then returns to room

a. The system should identify the guest as opposed to a staff member.

b. The AC should work to restore previous guest preference temperature.

c. If there are motorized curtain closers, then the curtains/blinds should open during daylight.

d. During daylight no lights should come on until the guest switches a light on.

e. After dark, then the welcome scene at the time of arrival should come on.

f. TV should not come on until guest switches it on.

4.15.7. Example Reports for Hotel Staff

a. Access available for housekeeping to determine vacant room for cleaning via mobile app.

b. Access available for housekeeping to determine occupied room but no guests inside for daily
cleaning and room make up/turndown.

c. Access for Housekeeping & Engineering to identify which rooms housekeeping staff are in, (this can
be timed based on hotel operations requirement).

d. Access available for engineering department to determine all the same items as housekeeping

◦ plus functionality of MEP systems:

▪ Lighting - (including individual lamp failure identification if smart LED lamps are installed)

▪ Room temperature

▪ Room humidity

▪ FCU valve position

▪ Chilled water/heated water temperature

▪ Fan speed

▪ Curtain position

▪ Electrical Meter reading kWh

◦ plus Links (interface with Computer Aided Facilities Management system). This can be multi-
functional - alerts on controlled modules, maintenance history (e.g. get information on last
service visit or complaint about a specific room, time, and damaged / repaired item).

e. User dashboard session access.
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f. Customizable dashboards and easily accessible to the hotel management / staff.

g. An optional mobile app could easily be downloaded and used to control A/C and Lighting.

h. DND, MUR, Bell module must have the ability to detect guest presence before staff push the bell.

i. Capture guest preferences such as temp, energy consumed, reported issues, number of stays, etc.

4.16. Test luminaire interoperability
The System Engineer tests all room lighting functions to ensure correct switching, dimming, and color
control of luminaires.

If there are issues these must be addressed or accepted by the customer. You must obtain customer
signoff to complete this step.


The Multiroom system supports all open standard dimming methods, providing
smooth, flicker free dimming. For complete assurance, pair with Philips Lighting
fixtures and drivers.

4.16.1. Project reference tools

• Third-party luminaire interoperability test report and waiver
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Chapter 5. Create Hotel Job file
The System Engineer produces a hotel master job file by adding the floor gateways, room profiles,
mockup room jobs, room alerts, and room mapping.



To use the Multiroom Dashboard and API with your mockup room, you must create a
hotel job with at least one room and install a licensed copy of Multiroom System
Manager. Later when on-site, the System Engineer will use this hotel job file to
complete the hotel configuration during acceptance testing.

Configure hotel job:

1. Add floor gateway

2. Add global areas to the hotel job

3. Add room profiles, zones, and services and enter the required properties

4. Define and add Room Alerts

5. Import mockup room job to room profile

6. Place devices and channels in zones

7. Configure notional energy

8. Configure DDRC-GRMS-E

9. Create device hex files

10. Add room mapping to create the initial Hotel Master Configuration

11. Install System Manager and configure integrations to test all features

Project reference tools

• Mockup room sign-off sheet (release for manufacturing)

• Mockup room job files

• Hotel Job file

• Room Controller IP address table (not required if using Dynamic IP addresses)

• Floor Gateway IP address table

• DIP switch settings table

• Site private key text file (must be kept secure)

5.1. Add floor gateway
Each floor gateway is configured with a unique IP address and floor offset (physical and logical address
range), for example, 1000, 2000, 3000 etc. A global logical range is also added to all gateways (areas
65000 – 65005) for logical messages to all rooms.

The Ethernet connections between SM, PDDEG-S, and DDRC-GRMS-E are secured via TLS encryption.


Disable the UDP default multicast, unicast, and all other unnecessary protocols and
ports before handing over the system to the customer. This is performed automatically
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when selecting the “Hotel Floor Ethernet Gateway” or “Hotel Room Ethernet
Gateway” options in the Bridge Configuration Wizard.

For more information on making the system more secure, please refer to the Ethernet
Gateway Commissioning Guide.

Default port numbers for Ethernet enabled devices

• Secure

◦ Port 443 for Trunk connections (System Manager - Floor Gateway)

◦ Port 50443 for Floor connections (Floor Gateway – Room Controller)

• Unsecure

◦ Port 50000 for Trunk connections (System Manager - Floor Gateway)

◦ Port 50003 for Floor connections (Floor Gateway – Room Controller)

Add a floor gateway to the job:

1. Click File > New and select  New Empty Job ( Ctrl  +  N ).

2. Enter the Hotel details in the Job Properties Editor.

3. Click  File Save As > Save As Job File to save the Hotel job to your PC.

4. Connect SB via an Ethernet cable and TCP/IP address to the PDDEG-S, or via a USB cable and PC
Node to the serial port.

5. Click  Insert Devices from Network ( Ctrl  +  L ) and select  Discover Network > Discover
Devices over Ethernet or search for the Ethernet gateway, or press the service switch. The gateway
appears in the Discovered Devices window.

6. Click  Add and Load Devices to add the gateway to the job from the Discovered Devices window.
This loads the default device configuration, admin password, and properties.

7. Click  Save to Device.

8. Click  File Save to save the job to your PC.

5.1.1. Create and upload the gateway certificate

A Site CA Certificate (Site Private Key) must be first be created or imported into SB. The Site CA
Certificate is then used to sign and upload a Device Site Certificate to the PDDEG-S gateways. When SB
has a Site CA certificate, it shows a  green lock icon at job level in the System and Building views.

SB shows a  green lock icon next to an PDDEG-S or Ethernet device when a Device Site Certificate has
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been uploaded. This enables SB/SM and Ethernet devices to securely connect to the PDDEG-S gateways
via a secure TLS TCP connection.

If the lock icon on an EG shows a  warning icon, then check the tooltip as it will indicate either:

• Device site certificate configured but Site CA used to sign the device site certificate is not found on
this machine. System Builder will be unable to securely connect to this device. Ensure correct Site CA
certificate is imported into this machine with the Tools menu, Set Site CA Certificate option.

• Device site certificate configured but doesn’t match Site CA configured in job. System Builder will be
unable to securely connect to this device. An updated device site certificate should be signed and
uploaded to the device.

Create/import site CA certificate:

1. From the Tools menu, select  Set Site CA Certificate to open the Site Certificate Selection
window.

2. If starting a new job, click the Create button to create a new site certificate.

a. After creating a new site certificate, you will be prompted to Export the site certificate and save
it in a secure location.

b. For additional security when exporting the site certificate, you must enter a password. This
password will be required by anyone importing the site certificate into another machine.

3. If someone has already started commissioning any of the devices and already created a site
certificate, they will need to export the certificate from their machine. You can then import the site
certificate to any machines used to commission or connect to secure Ethernet devices.


The Site CA certificate is stored in your machine, not in the job file. To allow another
machine to commission the same site you must securely send the job file, the Site CA
Certificate, and the password.


Having a lock icon in SB, a gateway, or a device simply means you have created and
uploaded a certificate. You still need to configure the secure connections (with the
Bridge Configuration Wizard) and save to device before you can connect securely.
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
The certificate placed in SM, the PDDEG-S, and the DDRC-GRMS-E must be signed by
the same Site CA Certificate.

 The certificate can be uploaded over a TCP/UDP or serial connection.

Create and upload certificate to the floor gateway:

1. Right-click the floor gateway in System view and select  Manage Certificate.

2. Select Certificate Type > Device Site Certificate for TLS Connections.

3. Click the Create and Upload button. After a minute or two, System Builder creates and uploads a
signed certificate file to the gateway.

4. Click the Close button.

5.1.2. Configure the floor gateway connections

We strongly recommend configuring secure connections between System Manager, the PDDEG-S, and
the DDRC-GRMS-E.

Configure floor gateway functions:

1. Right-click the floor gateway in System view and select  Bridge Configuration Wizard ( Alt  +  W ).

2. Select Hotel Floor Ethernet Gateway.

3. Select Static IPv4 Address and enter IP Address (and Gateway and Subnet mask if required).

4. Leave Web Server unchecked.

5. Click the Next > button.
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6. Under Trunk Connection, select TCP IPv4, Port 51443 and Secure checkbox.
(For unsecure Trunk Connection, select TCP IPv4, Port 50000)

7. Under Floor Connection, select TCP IPv4, Port 50443, Secure checkbox, and click the Next > button.
(For unsecure Floor Connection, select TCP IPv4, Port 50003).
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8. Click the  Add Physical Range icon and enter the Offset, Min, and Max values.

9. Click the  Add Logical Range icon and enter Offset, Min, and Max values.

10. Click the  Add Logical Range icon again and enter Offset = 0 (zero), Min = 65000, and Max =
65005 for the global areas.
Ignore any popup message boxes.

11. Click the Next > button.

 An SB Technician License is required to enter an address range without an offset.

69



12. Click the Next > button to accept the default metrics on the spur.
You can adjust the Polling Interval if required, otherwise proceed to the next step.

13. Click the Finish button, then click the Yes button to confirm.

14. Record the box number and IP address in the Floor gateway IP address table.

15. Click  Save to Device.

16. Click  File Save to save the job to your PC.


The Hotel Floor Ethernet Gateway option in the Bridge Configuration Wizard disables
the default UDP multicast connection when saved to the gateway. This means SB must
now connect to the gateway using a secure Ethernet trunk connection.

5.1.3. Add alternative floor gateway

Network gateway redundancy is provided by adding an alternative floor gateway for every primary
floor gateway in the project. The two floor gateways must be in different locations to ensure adequate
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redundancy.

The primary gateway and the alternative gateway are both connected via an Ethernet trunk connection.
If a floor gateway fails, then SM and the DDRC-GRMS-E room controller connections will switch over to
the other gateway (maximum switchover time is 2 minutes). The current connection is maintained
(unless the alternative gateway fails) even if the other gateway comes back online.

Both floor gateways are listed in the job’s master configuration. However, only the primary gateway will
show the connected DDRC-GRMS-E controllers in the network device tree. The two gateways should be
similarly named and have identical port, routing, and metric configurations. It is recommended to
commission the primary floor gateway and then copy the configuration to the alternate floor gateway.

Only these properties differ between the primary and alternative gateways:

• User settings

• IP address

• Box number

Configure network gateway redundancy:

1. Set Settings > Job Settings > Behavior > Enable network gateway redundancy to True.

2. Copy and paste the primary gateway to create the alternative gateway.

3. Select the alternative gateway, click Device Properties and set Is alternative gateway to True.

4. Open the primary gateway’s Device Properties tab and select the Alternative gateway from the
dropdown list.

71





The security certificate must be uploaded to both gateways.

Additionally, both the primary floor gateway and alternative floor gateway IP
addresses must be entered in the DDRC-GRMS-E Gateway Mapping Editor. Refer to
Configure gateway mapping.

5.2. Add global areas
Global areas are used for system-wide messages to indicate day/night or current season.

Add global areas:

1. Click the  Areas View tab.

2. Click  Insert New Folder and name it Global Areas.

3. Click the  Insert New Area dropdown list and select Add Specific Area.

4. In the Number field, enter 65000.

5. In the Name field, enter Day Night Tracking.

6. Click the OK button.

5.3. Add room profiles
Since most hotels have a limited number of room profiles, this eliminates much of the repetition
involved in adding rooms with identical configurations. The Room Profiles editor determines which
zones, features, areas and services are supported by each room profile. These are displayed in the
dashboard and are also available on the API.

The following room profile limitations affect the dashboard room view:

• 1 service of each type per zone (only 1 wake-up service per suite)

• 3 items per tile

• 5 different service types (HVAC, Wakeup Alarm, Door, Blind/Curtain, Lighting)

• 10 tiles per service

Set up room profiles:

1. Click  File > Manage Room profiles to open the Room Profiles dialog box.

2. Click  Add > Room profile.
You can also  Duplicate,  Delete,  Import, and  Export room profiles.

3. With the room profile selected, enter a Name, Description, and Type for easier identification.
The Type property determines the how the room is grouped and displayed on the dashboard.
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4. Enter a Group name if you have many room profiles. This property groups room profiles under
submenus in SB > File > Open Room Configurations.

5. If applicable, select Supports Floor Plan to enable the floor plan drawing to be shown on the
dashboard. This is mainly used for public areas and larger suites. Refer to Add a room configuration
floor plan.

6. You can set Display name as description to True to show the Room Description (from the Room
Mapping Table) instead of the room number on the dashboard. This is typically used for public
areas.

7. Select the supported room features for your project, e.g. Do Not Disturb, Make Up Room, Laundry
Pickup, Service Pickup, Humidity, Temperature for a guestroom. This ensures that only relevant
information is displayed on the dashboard’s Room View page. You can also set the Hotel Status
Area and Temperature Area to the area numbers reserved for these functions.

◦ Default Hotel Status Area = 3

◦ Default Temperature Area = 17
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8. Enter the estimated room profile base power in Watts for each room state (this should be estimated
by the hotel’s electrical engineer/specifier).

9. Enter sensor information to allow dashboard users to update occupancy timeouts and AntiStumble
nightlight timeouts for each room profile (See
/GIT/multiroom/build/multiroom/latest/index.html/multiroom/2.11/dashboard_guide/configurati
on/room_profiles.html[Multiroom Dashboard > Room & Suite Profiles]).
Select the number of ceiling sensors and AntiStumble sensors used in your room profile:

Example

A suite with:

◦ 2 x ceiling sensors (Bedroom + Bathroom)

◦ 2 x AntiStumble sensors (Bed Left and Bed Right)

Would have:

◦ Guest Occupancy: 4

◦ Staff Occupancy: 4

◦ Leaving the Bed Nightlight: 2

◦ Returning to Bed Nightlight: 2

10. Enter each sensor’s Device Code, Box number, and Motion Preset under each applicable category.
As in the example above, you may need to reenter one sensor’s info under multiple categories. This
allows each sensor to support different timeouts under various occupancy and room status
conditions. These timeouts are set via the dashboard’s Configuration > Room & Suite Profiles >
Room settings.
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11. With the room profile highlighted, click  Add > Zone to create as many zones as the room
requires. Each room profile must have at least one zone. You can enter a name for each zone for
easy identification. A zone can contain one of each type of supported service:

◦ HVAC

◦ Wakeup Alarm

◦ Door

◦ Blind and Curtain

◦ Lighting

Separately serviced areas (such as rooms with their own HVAC units and balcony doors) require a
separate zone.

12. With the zone selected, click  Add > Service to add each required service to the zone. Enter a
name for each service for easy identification. The Name property is displayed in the service’s tile in
the dashboard Room View. Use the  Up and  Down arrows to reorder the zones and services in
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the dashboard Room View.

13. Select each service (refer to the Example Services Properties screenshots below) to configure the
Features and logical Areas.

14. Click the  Export button to save a room profile to an editable XML file. This enables profile sharing
across multiple sites.
To load an exported profile, click the  Import button and follow the prompts.

15. Click the OK button to save your changes and close the Room Profiles window.

5.3.1. Example Services Properties

HVAC

• Default Temperature Area = 17

• Default Fan Area = 17



If using a floor plan for this room profile, select Service > HVAC Service in Floor Plan.
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Fan Speed Options

Switched 3-Speed Fan Variable 5-Speed Fan Variable 10-Speed Fan

Preset 1 - High
Preset 2 - Medium
Preset 3 - Low
Preset 4 – Auto
Preset 5 - Off

Preset 4 – Auto
Preset 5 - Off
Preset 7 - 20%
Preset 9 - 40%
Preset 11 - 60%
Preset 13 - 80%
Preset 15 - 100%

Preset 4 – Auto
Preset 5 - Off
Preset 6 - 10%
Preset 7 - 20%
Preset 8 - 30%
Preset 9 - 40%
Preset 10 - 50%
Preset 11 - 60%
Preset 12 - 70%
Preset 13 - 80%
Preset 14 - 90%
Preset 15 - 100%


For more information on fan speeds and HVAC profiles, refer to Configure notional
energy.

Wake-Up Alarm

• Default Wake-Up Alarm Area = 3
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Door

• Default Door Area = 3

• Default Door Channel = 10

• Default Room Safe Channel = 11

Blind and Curtain

• Default Curtain Area = 6
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Lighting

• Default Night Lights Area = 5

• Default Main Room Lighting Area = 10

• Default Bathroom Lighting Area = 11


Each Dashboard lighting tile supports up to 3 lighting areas, or a Master Lighting Area
+ 2 lighting areas.
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5.4. Define and add room alerts
Various room alerts can be specified for each room profile. They are displayed in the dashboard room
view and are available on the Hotel Integration API. Each room alert is added to a room profile and
applies to either the entire room profile or to a zone within the room profile. To trigger a room alert, the
corresponding hardware must first be configured in the room.

Define room alerts:

1. Click File >  Manage Room Profiles to open the Room Profiles editor.

2. Click the Room Alerts tab.

3. Click  Add and select the required room alert.

4. Edit the Name, Severity, Minimum Elapsed Time (before the alert is triggered) and the Notification
Frequency.
For Humidity, Soil Moisture, and Temperature, you must enter the Lower Threshold and Upper
Threshold values.

5. Room Alerts can be added more than once with different parameters as required.
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Click the beginning of the row to  Delete a room alert. You can also  Export and  Import
room alerts to/from an XML file.

Add room alerts to room profile:

1. Click the Room Profiles tab.

2. Select the required Room Profile or Zone.

3. Click  Add > Alert and the select the required alert. The alert will be grey if it has already been
added.

4. Click the Apply or OK button.
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
To enable the Dashboard to identify offline DALI drivers/lamps, DALI drivers must be
placed into zones in the room controller’s Outputs editor. Lamp Health must be
enabled.



Disabled room devices will:

• Not be seen in the dashboard room view Alerts and Health page

• Not be reported as offline

• Not trigger a Device Offline room alert

• Not be deployed to as part of a firmware or configuration deployment

• Have a  disabled device icon in the SB device tree

5.4.1. Room Alert Descriptions

Guestroom Alerts
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Room Alert Description

 Device Health Indicates the online/offline status of room devices
after the minimum elapsed time. Requires the
Device Online Status metric. To exclude devices, set
Device Properties > Device Identification > Room
device enabled to False.

 Entrance Door Indicates when the entrance door has been left
open for the minimum elapsed time. Requires a
room controller or DLLI8I8O Entrance Door Dry
Contact Input and/or Access Control System
message.

 Room Status Indicates the current room status after the
minimum elapsed time (requires a UI, Dashboard,
or PMS to set the room status):

 Do Not Disturb (Privacy)
 Laundry Pick Up
 Make Up Room
 Service Pickup

 Guest Well-Being Indicates that the room has remained occupied
but no-motion has been detected for the
minimum elapsed time. Default = 24 hours.

 Lamp Health Indicates that a DALI driver or lamp is offline.

Zone Alerts

Room Alert Description

 Door Status Indicates when a balcony door has been left open
for the minimum elapsed time. Requires a Balcony
Door Dry Contact Input.

 FCUC Filter Dirty Indicates the FCUC filter is dirty after the minimum
elapsed time. Requires an FCUC Air Filter Dry
Contact Input.

 FCUC Drip Tray Full Indicates the FCUC drip tray is full after the
minimum elapsed time. Requires an FCUC Drip
Tray Overflow Dry Contact Input.

 Humidity Indicates the humidity is below the Lower
Threshold value or above the Upper Threshold
value for the minimum elapsed time. Requires a
Humidity Sensor.

 Room Safe Closed Indicates that the safe door is closed when guest
checks in or out. Requires a room controller or
DLLI8I8O Safe Door Dry Contact Input.

 Soil Moisture[1] Indicates the soil moisture is below the Lower
Threshold value or above the Upper Threshold
value for the minimum elapsed time. Requires a
Soil Moisture Sensor.
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Room Alert Description

 Temperature Indicates the temperature is below the Lower
Threshold value or above the Upper Threshold
value for the minimum elapsed time. Requires a
network user interface with temperature sensor.

 Water Leak[1] Indicates bathroom water leak. Requires a room
controller or FCUC Bathroom Water Leak Dry
Contact Input.


DALI alerts (Channel offline, Driver/Ballast failure, Lamp failure) do not need to be
configured in the Room Alerts editor. Once DALI channels are placed into zones, DALI
alerts are automatically displayed in the dashboard. Device Health must be enabled.


Alert notifications are set up after SM installation in the SM Configuration Tool > Site
Settings.

5.5. Import mockup room job to room profile
After adding room profiles to the job, you can open them from the File > Open Room Configurations
menu. Each room profile is linked to a specific room configuration (mockup room). After making
changes to a room configuration, click Rebuild Master Job.


The room configuration tree has a light purple background color to show that you are
viewing a room profile.


Areas, System, and Building properties are unique in each room configuration, but Job
properties are common.


Room profiles that are mapped cannot be deleted. Before deleting, you must first
remove the profile from the room mapping table.

Add mockup room job to a room configuration:

1. Click File > Open Room Configurations and select the required room profile.

2. Click File > Import System Builder Job…, select the job file, and click the Open button to import the
mockup room job file for that room configuration.
(You can also manually add the mockup room devices and areas to the room configuration).

3. Click the Test button to confirm that there are no device conflicts.
If there are device conflicts, you must correct the mockup room job file before importing.

4. Click the Import button.
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5. Click the Close button, then click  File Save ( Ctrl  +  S  ) to save the job to your PC before selecting
the next room profile.

6. Repeat these steps for each room profile in your project.

5.6. Place devices and channels into zones
The Dashboard’s Control Center page reports device status by zone. User interface and sensor devices
must be placed in the room zone where they are located. For single-zone guestrooms, this can remain as
Unassigned (Master).

Place a device into a room zone:

1. Click File > Open Room Configurations and select the required room profile.

2. Select the device (UI or sensor).

3. Click the Device Properties tab.

4. Under Device Identification > Room zone, click the dropdown list and select the zone.

5. Repeat steps 1 to 4 for each UI and sensor in your room configuration.

DALI controller channels must have a room zone selected. This enables DALI alerts to be identified by
their location in the guestroom.

Place a DALI controller channel into a room zone:

1. Click File > Open Room Configurations and select the required room profile.

2. Select the DALI controller (the DDBC120-DALI and DDBC320-DALI are supported).

3. Click the Outputs editor tab.

4. In the Room Zone column for each lamp driver, click the dropdown list and select the zone.



If you have one or more DDBC120-DALI or DDBC320-DALI controllers in a room/suite,
the DALI drivers need to be localized using the Multiroom Dashboard. For more
information refer to
/GIT/multiroom/build/multiroom/latest/index.html/multiroom/2.11/dashboard_guid
e/control_center/room_view/manage_luminaires.html[Multiroom Dashboard >
Management Luminaires].
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 For security reasons, the DDBC320-DALI Ethernet port must be disabled.

5.6.1. Add a room configuration floor plan

If you have selected Supports Floor Plan in the Room Profile settings, then you can add a floor plan
drawing and associated fixtures and devices to the corresponding room configuration. The floor plan
will be displayed within the room view on the Multiroom Dashboard.

To view the floor plan in the Dashboard, the user can open the Monitor & Control tab, click the  Floor
Plan icon in the top right corner, and then select one of the following two views:

• Service & Health

• Lights & Devices

Light fixtures and devices need to be placed within a zone in their actual location on the floor plan.
However, service and health icons are automatically created and placed in the appropriate zone based
on the services selected in the Room Profile > Zone Properties.

The following service and device icons are shown on the dashboard:

Service & Health Lights & Devices

 Lighting

 HVAC

 Drapery

 Doors

 Lights

 Environmental

 Drapery

 Doors

 Occupancy


Note that a floor plan drawing must be cropped to only show part of the floor plan for
the specific room profile. To crop the floor plan please use relevant software
applications that can handle PDF files and vector drawings.


In File >  Manage Room Profiles, ensure you have added the zones and required
services to each zone before adding them to the floor plan.

 Currently, user interfaces are not shown on Multiroom Dashboard floor plans.
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Service & Health

Lights & Devices

Add fixtures and devices to a room profile floor plan:

1. Click File >  Manage Room Profiles to open the Room Profiles dialog.

2. Select the required room profile and set Supports Floor Plan to True.
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3. Click Apply or OK.

4. Click  Show Floor Plan Window, or  Float Floor Plan Window ( Ctrl  +  F9  ).

5. Click  Background Image > Select Background Image and select a PDF file that has a cropped
floor plan drawing showing the room.

6. On the floor plan toolbar, select  Draw Zone Region.

7. Click and drag a rectangle to draw a zone region for each zone in your room profile.

8. Enter the zone region name or keep the default name.

9. (Optional) Select a colour from the colour picker or enter the RGB values and click OK. You can use
this to visually group or differentiate zones.

10. Right-click the zone region to make changes.

If applicable, you can set a new center point to change the location of the zone label (and service
icons on the Dashboard). Right-click the zone region and select  Set Center Point and click in the
zone where you want the label to appear.

You can also add to the zone shape by drawing an adjoining zone and giving it the same zone
number.

11. From the System View or Building View tree, drag service placeholder devices into the floor plan
zone(s) where they are physically located.

12. Drag your DDRC-GRMS-E and other controllers onto the floor plan. These are not shown on the
dashboard.

13. In Building View, click the  Expand icon to show the DDRC-GRMS-E output circuits or DALI
controller drivers.
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14.

 Drag a circuit/driver to a location on the floor plan to add a fixture. The icon
shows a green + sign while dragging. You can scale the size of the fixture icon by dragging the red
handles.

15. Right-click a fixture to open the fixture context menu and make other changes to the fixture icon.
For example, you can click  Edit Properties to select a different fixture profile.

16. Continue dragging circuits/drivers to each zone until you have added all the fixtures in your room.

17. Right-click the controller in System View or Building View and select  Save to Device ( F12  ).

18. Click File >  Save ( Ctrl  +  S  ) to save your changes to the job.

5.7. Configure notional energy
Notional energy is calculated per room based on the estimated consumption of each load in the room.
This data is presented in the Multiroom Dashboard for reporting, analysis, maintenance, and
monitoring. Notional energy values are updated hourly on the dashboard and can be aggregated across
the whole hotel or per building/wing as required.

Notional energy properties are divided into three power categories:

• Lighting

• HVAC (Heating & Cooling)

• Base power

Project reference tools:

• Notional energy load sign-off sheet

5.7.1. Notional lighting power

Notional lighting power uses the estimated maximum load power, channel level, and run-time for
lighting circuits to arrive at a notional energy consumption value.

Configure notional power for lighting:

1. Click File > Open Room Configurations and select the required room profile.

2. In System view, select a controller and click the Outputs tab.
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3. In the Load (Watts) column, enter the maximum power consumption of the load in Watts for each
lighting circuit.

4. In the Power Category column, select Lighting for each lighting circuit.

5. Repeat steps 2 to 4 for each controller in the room profile. Ensure that you have included all
channels with connected loads.

6. Click  File Save to save the job to your PC.

5.7.2. Notional HVAC power

Notional HVAC power uses estimated HVAC energy consumption along with recorded run-time to arrive
at a notional energy consumption value. It is calculated from the values entered in an HVAC profile
based on manufacturer specifications, fan speed, and the difference between the setpoint and actual
temperature.

• If HVAC status is Cooling or Auto, and actual temp is equal to or higher than setpoint, then the
HVAC profile valve table is used for the power calculation. If actual temp is lower than setpoint, the
first row of the valve table is used.

• If HVAC status is Heating, the first row of the valve table is used for the power calculation.

• If HVAC status is Energy Holdoff or Off, then notional power is zero.

Configure notional power for HVAC:

1. Click Tools >  HVAC Profiles.

2. Click  Add to add a new HVAC profile (refer to the HVAC profile example for typical values).

3. Enter the values in the Cold Valve properties, as provided by the HVAC system consultant.

4. Enter the values in the Valve table, as provided by the HVAC system consultant.

◦ Click  Add to add another valve settings row.

◦ Select a row number and click  Insert to add a row above the selected row.

◦ Select a row number and click  Delete to delete a row.

5. Select the Fan speed type from the dropdown list (3-, 5-, or 10-speed) and select either Enter fan
voltage and current or Enter fan power. Enter the values in the Fan Speed table, as provided by the
HVAC system consultant.

6. Repeat the previous steps process for each HVAC profile used in the hotel.

7. Click the OK button to close the editor.
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8. After creating the HVAC profiles, click File >  Manage Room Profiles and select a room profile >
zone > HVAC service.

9. Select an HVAC Profile for the zone from the dropdown list.

10. Click the Apply button to save your changes, or OK to save your changes and close the Room
Profiles window.

5.7.3. Notional base power

Notional base power combines the estimated load for each room state (for non-controlled loads such as
minibar, coffee machine, TV, permanently powered outlets, etc.), along with the energy consumption
and run-time of plug loads connected to switched outputs, to arrive at a total notional energy
consumption value.

Base power has two components:
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• Fixed – Load in Watts specified per room state (non-controlled plug loads).

• Variable – Load in Watts specified for each circuit with Power Category = Power (controlled plug
loads).

Configure fixed base power:

1. Click File >  Manage Room Profiles and select a room profile.

2. In the Notional Energy group, enter the estimated power consumption in Watts for each room
state:

a. Base Power Checked in & Occupied

b. Base Power Checked in & Unoccupied

c. Base Power Checked out & Occupied

d. Base Power Checked out & Unoccupied

3. Click the Apply button to save your changes, or OK to save your changes and close the Room
Profiles window.

4. Repeat the previous steps for each room profile.

5. Click  File Save to save the job to your PC.

Configure variable base power:

1. Click File > Open Room Configurations and select the required room profile.

2. In System view, select a controller and click the Outputs tab.

3. In the Load (Watts) column, enter the maximum power consumption of the load, in Watts, for each
power circuit.

4. In the Power Category column, select Power for each power circuit.

5. Repeat the previous steps for each controller. Ensure that you have included all channels that have
loads connected.

6. Click  File Save to save the job to your PC.

92



5.8. Configure DDRC-GRMS-E

5.8.1. Create and upload the DDRC-GRMS-E certificate

A Device Site Certificate for TLS Connections must be uploaded to the DDRC-GRMS-E in each room
before you can configure a secure connection. To create a Device Site Certificate in the DDRC-GRMS-E,
you must first create/import a Site CA Certificate from System Builder Tools >  Set Site CA
Certificate. Refer to Create and upload the gateway certificate.


The certificate uploaded to SB/SM, PDDEG-S and GRMS-E must be signed by the same
Site CA Certificate.

 The certificate can be uploaded over a TCP/UDP or Serial connection.

 The DDRC-GRMS-E must have a box number.

Create and upload certificate to the DDRC-GRMS-E:

1. Click File > Open Room Configurations and select the required room profile.

2. Connect SB to the room network.

3. In System view, select the DDRC-GRMS-E load controller and click  Manage Certificate.

4. Set Select Certificate type to – Device Site Certificate for TLS Connections.

5. Click the Create and Upload button. After a minute or two, System Builder creates and uploads a
signed certificate file to the device.

6. Click the Close button.
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5.8.2. Configure gateway mapping

In the room controller, the gateway mapping lists the details of every floor gateway in the project. This
enables the installer to select the DDRC-GRMS-E to floor gateway connection by setting the ID2 DIP
switches.

Add gateway mapping:

1. Click File > Open Room Configurations and select the required room profile.

2. Connect SB to the room network.

3. In System view, select the DDRC-GRMS-E load controller.


Ensure that SB is using the correct box number for the DDRC-GRMS-E - this should
match the ID1 DIP switch setting on the controller. If you make any changes the
DIP switch setting, reset the controller before proceeding.

4. Click the Gateway Mapping tab.

5. Click  Add to add a gateway mapping row (you can also import and export the rows).

6. Enter the Primary IP4 Address, Alternative IP address and Port (50443) for the floor gateways and
the corresponding DIP switch number. Primary and Alternate gateways must be in the same subnet.

7. Repeat for every floor gateway in the hotel project.


To enable the Alternative IP address, open Tools > Settings > Job Settings > Behavior
and set Enable network gateway redundancy to True.
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5.8.3. Configure the DDRC-GRMS-E connections

Configure DDRC-GRMS-E gateway functions:

1. Right-click the DDRC-GRMS-E and select  Bridge Configuration Wizard ( Alt  +  W  ).

2. Select Hotel Room Ethernet Gateway.

3. If using DHCP, uncheck the Static IPv4 Address property or enter a static IP address (the Gateway
address, Subnet mask, and DNS server address properties are the same as in the Port Editor under
IPv4 properties but are not relevant for the DDRC-GRMS-E).

4. Click the Next > button.

5. Select Use Gateway Mapping Port and select the Secure checkbox. Then click the Next > button.


If you do not select Use Gateway Mapping Port, then you can manually enter the IP
address and port of a single floor gateway, however you will not be able to change
it with the ID2 DIP switches.

6. Click the Next button.
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7. Click the Next button.

8. Click the Finish button.

9. Press F12  or click  Save to Device.

10. Click  File Save to save the job to your PC.

5.9. Create device hex files
The device hex files must be sent with the hotel job file to enable device manufacturing and
preprogramming.

To complete the room profile configuration, you must unassign the box number from the room
controller as this will be set by the DDRC-GRMS-E DIP switches.

Set room controller box number to unassigned:

1. Right-click the room controller and select  Change Box Number.

2. Tick the Unassigned checkbox.

3. Click the OK button.

4. Click  File Save to save the job to your PC.

5. Repeat for each room profile.


Check the structure in System view. Ensure all required room devices have been added
under the room controller and all logical areas appear as expected.

96



A device hex file is the image that the factory uses to preprogram a room device. Each room device hex
file is exported from System Builder and forms part of the package that the system engineer sends to
Dynalite.

Save device hex file:

1. On your PC, create a Mockup Room folder and a Device Hex Files sub-folder.

2. Click File > Open Room Configurations and select the required room profile.

3. Within your selected SB room configuration, select a device to be exported.

4. Select File > Export > Device to Hex File. SB automatically names the file with the device type and
box number.

5. Select the required Mockup room and Device Hex Files folder.

6. Click the Save button.

7. Repeat the previous steps for each device in your mockup room.

8. Repeat this procedure for each room configuration.
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5.10. Add room mapping
SB uses the room mapping table to build all the rooms in the Master configuration. You can enter the
mapping data manually or import the data from a spreadsheet (.csv file).

The room mapping configures the offsets for each room. Ensure the offsets match the offsets in the
floor gateway. For example, a mapping entry for room 101 with an offset of 1040 will require that a
floor gateway exists with the offset of 1000.



At this stage it is only necessary to add the room mapping for your mockup rooms.
This enables you to ensure correct functionality before deploying to the complete
hotel. You can add to the room mapping table later when acceptance testing each
floor at the customer’s site.

Set up room mapping:

1. Click File > Open Room Configurations > Master to see the hotel job master configuration.
Opening the Master configuration builds the complete hotel structure. It is populated by each room
configuration in combination with the room mapping table.


If you have many rooms, when you click File >  Rebuild Master Job, it can take
a few minutes for SB to build the Master configuration.


The Master configuration can have different connection settings to a Room
configuration.

2. Click File >  Manage Room Profiles to open the Room Profiles dialog box.

3. Click the Room Mapping tab.
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4. Click  Add to add a room mapping entry, or select the beginning of a row to  Delete a room
mapping entry. Each room requires:

◦ Location (building, tower, wing, and/or floor separated by a /)

◦ Room Number (Do not enter leading zeros in the room number)

◦ Room Description

◦ Room Area Offset

◦ Room Profile

◦ FIAS Server (set to default unless additional FIAS servers are set up in SM)

◦ Room Mapping State (Active / Inactive)


The dashboard displays the Room Number for rooms and suites, and the Room
Description for all other room types.



The data in the Location column creates the folders and floors displayed in the
dashboard. These are sorted alphanumerically by default. To change the order,
click  Edit Building and manually drag the folders and floors to different
positions. The order is indicated by the Index value.

5. Add your mockup rooms to the mapping table.

6. Click the OK button to save the room mapping table and close the Room Profiles window.

7. Click  File Save ( Ctrl  +  S  ) to save the job to your PC.

5.10.1. Add Interconnecting Rooms (Room Linking)

Multiroom System Manager allows rooms with interconnecting doors or a shared entrance lobby
(vestibule area) to have a common doorbell, room status and occupancy status when connected. The
hotel must provide a list of rooms that can be physically connected to each other.

If interconnecting rooms have a shared lobby with an indicator panel, then this needs to be wired to
one of the rooms. An area in that room needs to be assigned to the panel to receive hotel status
messages from System Manager. If the shared lobby indicator panel has a doorbell button, then this
should be configured to send messages to this area.


If additional hardware is used to connect to the indicator panel, this will require a
separate room profile.

For rooms capable of being interconnected, Dashboard users will see a Link/Unlink Rooms button in
the top right corner of the Room view. When linked, the rooms in building and floor view will show the

 Linked icon.
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& PanelSt andalone 

Ent rance 
& Panel
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Example interconnected rooms with a shared lobby

Add Interconnecting rooms:

1. Click File >  Manage Room Profiles to open the Room Profiles dialog.

2. Click the Room Mapping tab.

3. Click  Edit Interconnecting Rooms.

4. Click  Add to add an Interconnecting Rooms entry, or select a row to  Edit or  Delete that
entry.

5. In the Add/Edit Interconnecting Rooms window, enter the connected room numbers.
Each entry requires a list of at least two room numbers, with each room separated by a comma.
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6. Select the appropriate checkboxes for rooms sharing:

◦ Room Status

◦ Doorbell

◦ Occupancy

7. For rooms with a shared lobby, select Contains Shared Lobby and enter the trunk area number for
the shared lobby area in one of the adjoining rooms (double-check that it is in the correct range
according to the mapping table).

8. Click the OK button.

9. Click the OK button again.


Supported Link Types > Occupancy must be selected for the Guest Well-Being alert to
function in interconnected rooms.

Behavior of interconnected rooms in System Manager:

1. When Room Status Link Type is enabled and SM receives a set or reset hotel room status message
(DND, MUR, LPU, RMS) and the room is currently linked then SM will send the hotel status message
back to the currently linked rooms. If a shared lobby area has been configured, then SM will also
send the hotel status message to the shared lobby area to update the status on the shared lobby
indicator panel.

2. When Room Status Link Type is enabled and rooms are unlinked (either manually from dashboard
or automatically when any of the rooms are checked out) and a shared lobby area has been
configured then SM will send to messages to reset (clear) all hotel status on the shared lobby
indicator panel (DND, MUR, LPU, RMS).

3. When Doorbell Link Type is enabled and SM receives a doorbell on or off message and the room is
currently linked, then SM will send the doorbell on or off message to all other rooms currently
linked. If a shared lobby area has been configured and SM receives a doorbell message from the
shared lobby area, then SM will send the doorbell message to all rooms that are currently linked. If
rooms are not currently linked, then no message will be sent by SM. Doorbell messages are DyNet1
opcode 0x6B Channel 1 with Preset 1 for Doorbell ON and Preset 4 for Doorbell OFF.

4. When Occupancy Link Type is enabled. If a room that is currently linked reports as occupied, then
SM will show all rooms as occupied in the dashboard. Only if all linked rooms are unoccupied shall
all linked rooms be shown as unoccupied. When a linked room reports as being unoccupied any
linked rooms that are still believed to be occupied by SM shall be sent a Door Closed message to
trigger an occupancy check in the room. Shared lobbies are not included in occupancy syncing.

Behavior of interconnected rooms in DDRC-GRMS-E

1. Linking/Unlinking rooms triggers the DDRC-GRMS-E tasks 60. Project Specific Room Linked Task
and 61. Project Specific Room Unlinked Task respectively. The shared vestibule is stored in
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persistent memory.

5.10.2. Importing and exporting room mapping

You can add room mapping entries for every guestroom, or click the  Export button to create an
editable CSV file and use a spreadsheet editor to complete the room mapping.

When importing the Room Mapping data into Excel:

1. Under the Data menu, select From Text/CSV.

2. In the Import window, select Do not detect data types and click the Load button.

3. Once the spreadsheet is complete, save your changes.

When on-site at the hotel, import the complete spreadsheet by clicking the  Import button to load
the saved file back into the Room Mapping table.

5.11. Install System Manager for the mockup room
To use the Multiroom Dashboard and integrations with your mockup room, you must create a hotel job
with at least one room and install a licensed copy of Multiroom System Manager. This allows you to
check the room logic with the Dashboard and third-party systems.

System Manager Server for the customer will be installed later at the hotel site. For more information
refer to System Manager installation.

[1] Not available to all markets. Contact your Interact representative for more information.
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Chapter 6. Order Preparation

Prepare order:

1. Prepare IP address tables

2. Prepare and submit files

3. Factory preprogramming and preassembly

Project reference tools

• Mockup room sign-off sheet (Release for Manufacturing)
This document is to verify the agreement between Sales and the Customer.

• Hotel job file

• Device hex files

• Room profile hardware BOQ

• User interface labeling artwork

• Room controller IP address table

• Floor gateway IP address table

• Site private key text file (must be kept secure)


Hardware BOQ (SAP) and User interface labeling artwork (via online configurator)
follow existing process.

6.1. Prepare IP address tables
Prepare a room IP address table, listing the DDRC-GRMS-E in every guestroom/public area in the hotel.

6.1.1. Example IP Address Tables

Room Controller

Room number IP address Host name Box number ID1 DIP switches

101 192.168.241.101 GRMS-E#101 1 1

102 192.168.241.102 GRMS-E #102 2 2

103 192.168.241.103 GRMS-E #103 3 3

 This table is not required if the room controller IP addresses are assigned by DHCP.

Prepare a floor gateway IP address table, listing every floor gateway in the hotel.

Floor Gateway

Floor number IP address Host name Box number ID2 DIP switches

Floor 1 192.168.241.1 EG#1 241 1
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Floor number IP address Host name Box number ID2 DIP switches

Floor 2 192.168.242.1 EG#2 242 2

Floor 3 192.168.243.1 EG#3 243 3


Depending on the number of rooms on each floor (e.g. >30) there may be more than
one floor gateway per floor.

6.2. Prepare and submit files
When all key stakeholders have agreed on the room logic and completed the mockup room sign-off
sheets (release for manufacturing), and the System Engineer has completed the hotel job file, they
submit the order to Dynalite for production.

 After sign-off, changes or new requests are chargeable.

The customer can choose either factory preprogramming (recommended) or on-site programming.

6.2.1. Factory preprogramming (recommended)

May have a longer lead time to assess the ETO request, with shorter on-site commissioning time as
devices will be preprogrammed.

Ordering follows the standard ETO process. The System Engineer sends an Architecture STR ETO Request
with attached files to the Dynalite International Order Desk (dynalite.sales@signify.com) to start the
ETO process.

The commissioning engineer sends the following files to Dynalite: * Mockup room sign-off sheets
(release for manufacturing)
This document is to verify the agreement between Sales and the Customer. * Hotel job file * Device hex
files * Room profile hardware BOQ * User interface labeling artwork * Room controller IP address table *
Floor gateway IP address table * Site private key text file (must be kept secure)


Hardware BOQ (SAP) and User interface labeling artwork (via online configurator)
follow existing process.


The Dynalite factory will create and upload Device Site Certificates to preconfigured
PDDEG-S gateways. In this case they will share the Site CA Certificate with the assigned
commissioning engineer representative.

Preconfigured products will be issued a unique 12NC. The 12NCs are raised by the factory based on the
BOQ and project requirements.

The factory preprograms all floor gateways and room devices (controllers, dry contact inputs, sensors,
user interfaces) and ships the finished products to the job site.

6.2.2. On-site programming

May have a shorter lead time as devices are ordered directly from Dynalite, with longer on-site
commissioning time as devices are not preprogrammed.
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Ordering follows the standard Dynalite product ordering process. The commissioning engineer
programs devices on site using the Hotel Job file Master Configuration and saves the configuration to
each device.

• DDRC-GRMS-E: Box numbers and gateway mapping are set by DIP switches.

• Antumbra multi-configuration: Initial box number set by SB, then configuration set by DIP
switches.

• Other room devices: Box numbers are set by SB.

6.3. Factory preprogramming and preassembly

6.3.1. Antumbras

One or more Antumbra multi-configurations are programmed into the DACMs and labelled for
identification.

Example multi-configuration table
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6.3.2. AntiStumble Sensors

AntiStumble sensors are combination of a DUS360CR sensor and the DUS180WR stick-on cover plate.
Custom colors can be ordered.

6.3.3. Modular Controllers

The factory preassembles the controllers as specified. They will insert the specified control modules into
the correct positions in the DDMC802 controller.

6.3.4. DIN Rail Enclosures

For fast and consistent installation, we can supply preassembled enclosures. Deployment is faster onsite
and the risk of bad interconnections in the enclosure is removed. These can be ordered separately by the
electrical contractor and may be a tender requirement.

The DH2X24 and DH3X24 DIN rail enclosures can be ordered empty or prepopulated with devices and
network wiring.

• Ordering follows standard ETO process.

• Dedicated 12NCs to be raised by factory based on the Bill of Materials (BOM) and project
requirements.

• Additional costs to AFSP communicated by the factory to local market based on BOM and project
requirements.

• Sales organizations to create final BOM with End User/VAP pricing.

• Codes activation to be completed across all supply chain prior to ordering.

• Factory to provide forecasting and delivery schedule to meet project requirements.

6.3.5. Dedicated Server Rack

The System Centre or Certified System Integrator assembles and pre-wires shelving with DIN rails. They
can arrange for a number of PDDEG-S gateways on each shelf, consuming 2U each with clearance. They
may also offer a dedicated rack with gateways, servers, backup, monitors, etc. fitting into 48U.
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Chapter 7. On-Site Configuration

Deploy Hotel System:

1. Install system.

2. Save device configurations.

3. Perform acceptance testing.

Project references

• System Installation Guide

• Room layout (showing lights, UIs, sensors, and other services)

• Electrical drawings (including elevation drawings to show UI locations)

• ID1 DIP switch settings table

• ID2 DIP switch settings table

• Room IP address table

• Snagging list

7.1. Installation
Prepare a System Installation Guide for the installers. Then, prior to installation, brief the installers on the
system installation tasks.

The System Installation Guide must include:

1. Instructions to connect and test room and corridor devices, wiring recommendations, and cable
length estimates.

2. The DIP switch settings tables to instruct how to set the DIP switches for each room controller.

3. Antumbra multi-configuration DIP switch settings table.

4. Drawings to identify correct location of UIs (and UI buttons) and sensors (sensor coverage diagrams).

5. Wiring instructions (in-room wiring run).

6. Hotel room numbers from the hotel operator (not from the builder).

7. Device labels to identify the room devices and floor gateways.



On the room controller, it is important that the DIP switches are set before powering
on. If DIP switches are changed, reset the controller by holding the service switch for
more than four seconds. It can take up to 30 seconds for the controller to come back
online.

Room controllers may be room-specific (if using static IP addresses), but all other room devices are
room-agnostic. This allows the contractor or hotel engineering to easily swap in spare devices/parts as
needed.

Floor gateways are floor-specific due to static IP addressing. Floor gateways must be installed according
to the building’s IT requirements.
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Testing and validation of the installation is the responsibility of the installer. Suggested installer tests
include:

1. Service switch on each controller (as per front label)

2. Walkthrough test

3. Emergency lighting test

7.1.1. Example DIP Switch Settings Tables

7.1.2. Room Controller ID1

This sets the room controller box number and room address offset.
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7.1.3. Room Controller ID2

This sets the room controller connection to a floor gateway (via gateway mapping).
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7.2. Saving device configurations

 These steps only apply to devices that were not preconfigured in the factory.

For each floor gateway, add and configure a floor gateway in the hotel job:

1. Connect SB via Ethernet or serial connection.

2. Create and upload certificate.

3. Run the Bridge Configuration Wizard.

4. Save device configuration and check the Ethernet trunk connection.

Refer to the steps in Add Floor Gateway.

For each room, add and configure a DDRC-GRMS-E in the hotel job:

1. Open the room configuration and select the DDRC-GRMS-E in System view.

2. Connect SB via Ethernet or serial connection.

3. Adjust the room controller DIP switches.

4. Create and upload the certificate.

5. Change the room device box numbers to match the room profile.

6. Save the configuration to all devices in the room.

Refer to the steps in Create and upload the DDRC-GRMS-E certificate, then complete the steps below.

To save the configuration for the room controller and room devices, you need to open two instances of
System Builder.

• SB with new empty job to change device box numbers.

• SB with hotel job to be used as a reference for the room configuration device box numbers and to
save the configuration to each device.

Change room device box numbers:

1. Go to each room and plug the commissioning PC into a USB PC node, then plug the USB PC node
into a DyNet socket that is connected to an RS-485 network serial port.

2. Ensure the room controller DIP switches are set for the correct room and all room devices are
powered up.

3. Launch SB with the hotel job
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4. Launch a second instance of SB with a new empty job and connect using a serial connection.

5. Click  Insert Devices from Network ( Ctrl  +  L  ) and:

a. Search by device code for the required room devices
OR

b. Sign on each room device by pressing the service switch or holding down a UI button
OR

c. Turn the room circuit breaker OFF then ON (all devices will power up and sign on).
Signed-on devices appear in the Discovered Devices window.

6. Enter a new box number for each room device to match the box number in the hotel job room
configuration.

7. Click  Change Box Numbers. The Apply New Box Numbers window opens and saves the new
box numbers to the listed devices.

8. If applicable, Create and upload the DDRC-GRMS-E certificate.

9. Close the Discovered Devices window, then close this instance of SB.

Save device configuration:

1. Open the hotel job file.

2. Click File >  Manage Room Profiles to open the Room Profiles dialog box.

3. Click the Room Mapping tab.

4. Click  Add to add a room mapping entry (you can add all entries for the floor).

5. In the new row, enter the details for the current room (or copy and paste from an existing row then
modify as needed).

6. Click the OK button to save the room mapping table and close the Room Profiles window. The

111



Master Configuration is rebuilt and now includes the new room.

7. In the Master Configuration System view, right-click the room controller for the room you are
configuring and select  Connect….
Ensure the Machine Connection Settings are configured to use a serial connection (SB lower right
corner shows Connected-COM).

8. Select the room controller and all room devices by holding the Ctrl  key and clicking each device.

9. Right-click one of the selected room devices and select  Save to Device.

10. In the Save Data To Device window, select Resave all device data and click OK.
The full configuration data is saved to each device.

11. Select each room device and click  Send Device Sign-on ( F6  ).

12. Check the Network Log to verify that each device responds correctly.

13. Click  Disconnect.

14. Click  File Save to save the job.

7.3. Acceptance testing

7.3.1. Server room

Check that IT equipment has been installed and configured correctly. All Ethernet gateways must be
patched and powered up. The patching panel may be in the IT server room.

7.3.2. Guestroom

The integrity of the cabling and device installation must be verified before accepting the handover from
the installer. Installation and electrical testing of rooms is entirely managed by the electrical contractor.
You must verify that all devices have been installed according to instructions and the installer has
executed the electrical tests and signed off that all tests have passed.

Project reference tools

• Snagging list
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Verify network devices:

1. Open the hotel job file/database.

2. Connect SB to the network, either via the Ethernet trunk or directly to a floor gateway.

3. Add the room mapping entries for the rooms you will be testing.

4. Starting from the first room, right-click the Ethernet bridge (if using) and select  Send Sign-on.
Note the response from the Network Log.

5. Right-click the DDRC-GRMS-E and select  Send Sign-on.
Note the response from the Network Log.

6. Under the DDRC-GRMS-E, right-click each device folder and select  Sign-on all Devices.
Observe the Network Log for responses from each device.

7. Record the responses from all room devices in the Snagging list.

8. Repeat for each room in the hotel.


Be aware of where SB is connected. On the trunk side of the gateway, you will see
addresses with the floor offset. On the spur side of the gateway, you will see addresses
without the floor offset.



If DIP switches are duplicated on two DDRC-GRMS-Es then in SB you will see devices
with duplicate box numbers. Alternatively, if you set all rooms to the same room
status, such as, DND or MUR, and filter your Dashboard Control Center floor view to
show this status, then the duplicate room number will be missing.


If two floor gateways have duplicate offsets, you will be controlling rooms on two
different floors at the same time. Recheck the Bridge Address Ranges for each floor
gateway.

Device box numbers are already preprogrammed in the factory. Except for DALI localization and
problem investigations, there should be no need to attend rooms. Everything is either predefined or
worked on from a central location. This reduces your per-room labor allocation to approximately 20
minutes per room (5 minutes each for testing, problem reporting, retesting, and for unforeseen support
requirements).

Acceptance testing process:

1. Device Test - When the contractor believes a floor is complete, it is handed to the System Engineer
to test rooms from the server.

2. Contractor Snagging - After testing, report any devices you can’t reach to the contractor to check
and remedy.

3. Device Retest - After snagging, the rooms are retested by signing on all the devices (controllers,
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sensors, and user interfaces)

4. Dashboard Room Setup - Once rooms pass all tests, they are added (partial or full floor) onto the
dashboard. This acts as the handover to the hotel operator.

7.4. DALI Pairing



If you have a DDBC120-DALI or DDBC130-DALI controller, the DALI drivers must be
localized using the standard DALI enumeration process in System Builder, or via the
dashboard - refer to
/GIT/multiroom/build/multiroom/latest/index.html/multiroom/2.11/dashboard_guid
e/control_center/room_view/manage_luminaires.html[Multiroom Dashboard >
Management Luminaires].



To resolve issues where duplicate or incorrect DALI addresses are seen in the
dashboard’s Manage Luminaires page, follow these steps:

Clear DALI controller addresses:

1. Open the hotel database in SB.

2. From the Master configuration, right-click the DALI controller for the specific room
and select:

◦  Remove Unpaired DALI Drivers. This removes the surplus driver
information in the job and in the controller when drivers have been removed
from the room.
OR

◦  Clear DALI pairing. This does not factory-set the device in the room; it
simply clears any DALI status and pairing information in the job for that
specific controller.

3. Save the database in SB. If using the server machine, this will trigger the SM server
to reload the changes.



To load and sync DALI addressing for DALI drivers have been enumerated and paired
by running SB in the room. Follow these steps:

Load and Sync DALI Pairing:

1. Open the Hotel database in SB.

2. From the Master configuration, right-click the DALI controller for the specific room
and select  Load and Sync DALI Pairing. This loads the DALI addressing from the
controller into the master job so it will show on the dashboard.
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3. Save the database in SB. If using the server machine, this will trigger SM Server to
reload the changes.
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Chapter 8. System Manager Installation

Install Interact Multiroom System Manager:

1. Install database management software

2. Configure Microsoft Internet Information Services

3. Install System Manager prerequisites

4. Install System Manager software suite

5. Check server operation

Project reference tools:

• System Manager and associated installation files

• Room mapping table

• Hotel job file

Room / Space

Lighting

Room
Controller

Power Sockets HVAC Blinds / Curtains Fan

UI (Wake-Up Alarm
& Thermostat)

UI Sensor
Door / Window Sensors

Services
• HVAC
• Wake-Up Alarm
• Door
• Blinds / Curtains
• Lighting

Floor Ethernet Gateway

Other Rooms & Spaces

System Manager Server

Other Floors

API Multiroom Dashboard

PMS BMS Access Control
(Saflok, VingCard, etc.)

Database

8.1. Install database management software
Multiroom System Manager requires database management software for the HospitalityDashboardDb,
UserManagementDb, EnergyDb and DataAccessDb databases. You must install the database
management software and configure Internet Information Services (IIS) before installing other System
Manager components.

The options are:
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• PostgreSQL database, version 12 or 13.
Download the PostgreSQL installation package from https://www.postgresql.org/download/
windows/

• Microsoft SQL 2019 database or later.
This may be used where the hotel has an existing Standard or Enterprise license. For more
information on downloading and installing Microsoft SQL server, please refer to
https://www.microsoft.com/en-au/sql-server/sqlserver-2019.



Databases can be configured to be local (on the SM Server machine) or remote (on
another machine on the customer’s LAN). Please refer to Dynalite FAQ #477 - How can
I connect System Manager to a Remote SQL Database. If using SQL on a different
machine from the System Manager Server, you will need to note the following:

• Server name

• Instance name

• SQL username

• SQL password

Install PostgreSQL database:

1. Right click the PostgreSQL setup file from an explorer window and select Run as administrator to
open the PostgreSQL Setup Wizard.

2. Click Next > in the PostgreSQL Setup Wizard.

3. Click Next > for Installation Directory.

4. Click Next > for Select Components.

5. Click Next > for Select Data Directory.

6. Enter database superuser password and retype to confirm.


The database management software password is encrypted so ensure you store a
copy of the password in a secure location for future reference. The password is
required later when installing System Manager.

7. Click Next > for Select Port Number.

8. Click Next > and Select Your Language and Location, if applicable.
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9. Click Next > for Display Pre-Installation Summary.

10. Click Next > for Ready to Begin Installation.

11. Untick the Launch Stackbuilder checkbox and click Finish.

8.2. Configure IIS
On the SM Server, open Windows Control Panel > Programs and Feature > Turn Windows features
on and off.

Click the checkbox to enable Internet Information Services, and additional checkboxes as appropriate
for your operating system.
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Windows 10
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Windows Server 2016
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8.3. Install SM prerequisites
In Windows Explorer, right-click the System Manager Prerequisites setup file and select Run as
administrator (Philips.Dynalite.System.Manager.Prerequisites_v1.5.0.2.exe).

Once the prerequisites are installed, the wizard ends automatically.



SM Prerequisites installs Microsoft SQL Express 2019 (not used for Multiroom) and
creates the instance “\EMSERVER". This is installed by default and must be uninstalled
if using Microsoft SQL 2019 Standard or Enterprise.

If required, Microsoft SQL databases can be encrypted. For more information on
Microsoft SQL 2019, please refer to the relevant Microsoft documentation.

8.4. Install Multiroom System Manager


Ensure that you install Multiroom System Manager (not Dynalite System Manager)
package.

Install Multiroom System Manager software suite with PostgreSQL:

1. Right-click the installer (.exe) and select Run as administrator.

2. Select the program features to install and click Next >, then click Install.
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3. Click OK. This message confirms that the three standard System Manager Microsoft SQL Express
databases are set up (these are not used for Multiroom).

4. Select the database management system (default: PostgreSQL).
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
For more information on using Microsoft SQL Server with Multiroom System
Manager, please refer to Dynalite FAQ #682 Set up Multiroom System Manager to
use Microsoft SQL 2019 Standard/Enterprise edition.



If you have made an incorrect database server selection, you can change from
MSSQL back to PostgreSQL by modifying the System Manager installation from
Windows - Programs and Features and change the selection (No data shall be
migrated).

5. When prompted, enter the password previously created for the PostgreSQL database super user
account and click Next >.
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6. To create the Database name and User name, enter the same password twice and click Next >.

7. After the wizard has successfully created the Data Access database and user, click OK.
The installer will install the remaining System Manager components.
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8. To provide browser access to the Dashboard and APIs via your own domain: select the SSL certificate
and enter the domain name, then click Next >. We recommend selecting a certificate from the
certificate store (supplied by the hotel), or the wizard can create a self-signed certificate for the
specified domain.
Spaces are not allowed in the certificate friendly name.
A self-signed certificate created by the installer is updated in IIS Server certificates (expiration is 2
years from current date).
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9. Click Yes to confirm the URL.

 The domain name must have a minimum of three parts, e.g. myhotel.example.com


Domain names either need to be registered by IT on their DNS servers, or on each
client machine’s hosts file, to resolve the domain name to the SM server IP address.
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
The certificate and domain can be changed later by rerunning the install package,
or by opening the  Data Access Service Configuration app.



Only the Interact gateway URL (e.g. https://dashboard-
local.hospitality.interact-lighting.com) is required to be trusted on client PCs.
This is the only address that is accessible via the local network. After installation
you can find the gateway URL in Windows IIS. This is the URL for all dashboard,
API, and WebSocket connections. The gateway then routes requests to the
individual APIs as in the example table below:

Domain IP:Port Local/Rem
ote

https://myhotel.hospitality.interact-
lighting.com

[SM server IP
address]:443

Remote

https://api.hospitality.interact-
lighting.com

127.0.0.1:443 Local

https://usermgmt.hospitality.interact-
lighting.com

127.0.0.1:443 Local

https://dashboard-
local.hospitality.interact-lighting.com

127.0.0.1:443 Local

https://energyapi.hospitality.interact-
lighting.com

127.0.0.1:443 Local

https://dynalitecontrolapi.hospitality.inte
ract-lighting.com

127.0.0.1:443 Local

https://publicapi.hospitality.interact-
lighting.com

127.0.0.1:443 Local

10. Click the Finish button to complete the installation.
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8.5. Data Access Configuration


If you have followed the Multiroom SM installation wizard steps, you are not required
to make any changes to Data Access Configuration.

You can access Data Access Configuration via the Windows Start Menu under Philips Dynalite > 
Data Access Service Configuration to make changes to the database settings and credentials.

The Data Access Configuration window shows the current Data Access Service Status and buttons for
each section.
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Manage Database

The Manage Database dialog provides settings to select the database type, server address, and
superuser credentials that were entered during the SM installation process.

Manage System Dashboard

Do not change these settings, they are not relevant to Multiroom System Manager.
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Manage Interact Multiroom

The Interact Multiroom Configuration window includes buttons to access URLs Overview, Certificate
Configuration, and Manage Multiple System Managers.

URLs Overview

The URLs Overview dialog shows the current Dashboard and API URLs for your system. Click the links to
launch them in your browser. Click the  icon to copy the URL to the clipboard.
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Certificate Configuration

The Certificate Configuration dialog allows you to configure the host name and domain of the
multiroom dashboard and APIs, and to select or create an SSL certificate for the webserver.

Manage Multiple System Managers

The System Manager Server dialog enables you to link multiple SM servers that may be required for
very large sites with thousands of rooms. Data from all SM servers is integrated into a single Multiroom
Dashboard.
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System Checkup

The System Checkup dialog box shows notifications of upcoming certificate expirations so you can
update the relevant certificates.

System Hardening

The System Hardening dialog provides a list of security recommendations that you can apply to the
server machine.
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Log Viewer

The Log Viewer dialog combines log messages from multiple text file logs on the server machine. Logs
can be filtered by service, message level, time, and date.

Performance Monitor

The Performance Monitor dialog shows graphs of application and service performance metrics. You can
add time filters, and select different metrics or counters to be logged. Some built-in metrics are
available, and any Windows Performance Counters available on the machine can be configured to be
logged and displayed.
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8.6. Check SM Server Operation
In Windows Task Manager Services, ensure that the four Philips Dynalite System Manager services are
running.

If the system is connected and there is live data going into the TrendDB, then you can check
C:\ProgramData\Dynalite\DataAccess\Logs\DataAccessServer.log to see incoming sync messages.
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8.7. Install SM clients, if applicable


The client software is not required for hotel staff but may be required for engineering
staff. The initial superuser account on the server is likely to be sufficient for most
installations.

You can install multiple versions of the client software on different PCs to access System Manager
Server.

Install SM client:

1. Copy the installation files located in the following folder on the SM server:
C:\Philips Dynalite\System Manager\System Manager Client

2. Run setup.exe on the user’s PC.

3. In Windows, click  System Manager to open the System Manager client.

8.8. Security Hardening
Ensure that you perform system and OS hardening to prevent unauthorized access to the system.

• For information on hardening the Windows server, please refer to the OS Hardening Guide.

• For information on hardening Philips Dynalite System Manager software and hardware devices,
please refer to the System Hardening Guide.
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Chapter 9. System Manager Configuration

Configure System Manager:

1. Import Site CA Certificate

2. Request licenses

3. Load Hotel job file into System Manager

4. Configure site settings

5. Configure system alert

6. Configure guest languages

7. Configure SM client user access

8. Configure secure access to the Multiroom Dashboard

9. Open Dashboard

9.1. Import Site CA Certificate
To establish secure Ethernet connections, you must open System Builder on the SM Server machine to
import a Site CA Certificate (Site Private Key) and save the job/database. The Site CA Certificate must
have been previously exported from the commissioning machine. The Site CA Certificate and password
must always be stored and sent securely.

SB is used for site certificate management and uploading to devices. During commissioning, the Site CA
Certificate is used in the job to create and upload Device Site Certificates for TLS connections between
gateways and Ethernet devices, and between gateways and SB/SM.

Only a PDDEG-S can be used for secure connections. To ensure end-to-end security, each PDDEG-S and
Ethernet device must be configured for secure connections in the job and saved to devices before
importing the job into SM.

Import Site CA Certificate:

1. Open System Builder on the SM Server machine.

2. In the Tools menu, select  Set Site CA Certificate to open the Site Certificate Selection window.
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3. Click the Import button and select the exported certificate (.pfx).

4. When prompted, enter the certificate password.

5. Click the OK button.

6. Click the OK button.
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7. Save the job/database.

9.2. Request Licenses
The Multiroom System Manager license automatically enables the API and Hospitality services.

License fees are based on number of rooms, license duration (years), and feature tier (Advanced or
Enterprise).

Request and apply license:

1. After System Manager is installed, run the  System Manager Configuration tool.

2. Click the Request License button.

3. Enter the site details and select the required license features (Red fields are mandatory).

4. Click the Save License Request button and send the request via email.

5. The support team contacts the sub-segment manager to verify that the software + service
entitlement is logged in C4CS and matches an order in SAP.

6. The support team creates the license with the entitlements embedded and issues it to the requester
by replying to the email with the attached license file within 24 hours.

7. Save the license file to a folder on the server.

8. Click the Apply License button.

9. Browse and select the license file System Manager.license.

10. Click the Open button. The license information is displayed at the bottom of the Configuration
window.
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

The request uses the standard email application on the computer to generate an email
to support.controls@signify.com. If no email client is installed, the Save License
Request button can be used to save the license request to a file to be sent later or
from another computer.

9.3. Load Hotel Job file into System Manager
To complete the System Manager configuration, you need to run the  System Manager
Configuration tool and create a new database from the hotel job file.

Load hotel job:

1. Click the Run Quickstart button, select Start from a System Builder job file and click the Next >
button.

2. Click the Browse button, select the job file and click the Open button. Click the Next > button.
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3. Enter the Server Name and Database Name and click the Next > button.

4. Click the Next > button, since you have already licensed the server.

5. Enter the domain name and username for the admin user, or click the Choose button to search for a
user.
Unselect the Allow guest users to logon checkbox.

6. Select the Location and Time Zone information and click the Next > button.

7. Click the Execute button and Finish button to create the databases and user.

9.4. Configure Site Settings
Configure site settings for API access:

1. Run the  System Manager Configuration tool.
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2. Click Site Settings.

3. Select Data Access.

4. Select the Enable Web API checkbox.

5. Consult with integrated systems engineers regarding Hotel Settings for FIAS and Access Control.

 For more information refer to Integration.

9.4.1. Startup Polling

If SM server restarts, then room statuses may not be completely synchronized with the Dashboard. The
system resynchronizes all statuses as it receives new events.

For small hotels (<250 rooms), setting Site Settings > System Settings > Hotel > Enable hotel status
polling at server startup to True allows the server to poll all the rooms at startup to immediately
synchronize the dashboard.

However, for larger hotels this setting generates too much network traffic, and must remain set to False
(default).

9.5. Configure System Alert
These settings are for initial configuration of system alerts for PMS (FIAS) and Floor gateway
connections. You can also modify the system alert configuration in the Multiroom Dashboard, under
/GIT/multiroom/build/multiroom/latest/index.html/multiroom/2.11/dashboard_guide/configuration/
alert_definitions.html[Configuration > Alert Definitions > System Alerts].

Configure system alert for PMS (FIAS) and Floor Gateway Connections:

1. Run the  System Manager Configuration tool.

2. Click Site Settings.
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3. Expand Hotel Settings and select System Alert.

4. Select PMS (FIAS) Connection or Floor Gateway Connection.

5. Select the Enabled checkbox.

6. Enter a name for the alert (this will be displayed on the dashboard)

7. Select the First after time period from the dropdown list.

8. Select the Repeat alert time period from the dropdown list.

9. Click the Save button.


The System Alert status is shown by clicking the  globe icon in the top right corner
of the dashboard. First and Repeat alerts are sent on the API WebSocket. However, the
alert icon on the dashboard will persist until the connection is restored.

9.6. Configure SMTP and Notifications
System Manager can be configured with an SMTP server and custom messages to notify specified staff
members via email when an alert is triggered.

Configure Alert Notifications:

1. In SM Configuration > Site Settings > SMTP Server, enter the SMTP server details.

2. Click the Test Primary and (if applicable) Test Backup buttons to confirm the connection.
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3. In SM Configuration > Site Settings > SMTP Message, select the message Importance, Message
Template and Custom subject. A preview of the message template is shown in the window.

4. In SM Configuration > Site Settings > Notifications, click  Add to create a new notification.

5. Enter a name for the notification profile.

6. Check the Alert Types for which the user will be notified.

This creates the notification profiles. Email recipients must then be added to the required profiles, so
they are notified when an alert occurs.

Add Recipients:

1. In the Notifications Recipients tab, click  Add or  Add System Manager User. The Add Email
Recipients dialog is displayed.
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2. Enter the Name and Email address of the recipient or select the recipients from the User account list.

3. Click the Test button to verify the email address of the recipient.

4. Click OK. The recipients are added to the Recipient list.

9.7. Configure Guest Languages
FIAS allows the PMS to select a guest language on check-in and reset the language on check-out. The
language for the room is reflected in the hotel dashboard and on the AntumbraDisplays in the room. If
no language is received from the PMS or it does not match an available language, the display will
continue to show the language menu.

To support guest languages, the SM Server must have the languages made available and the
AntumbraDisplays should be preconfigured with multi-language pages. These are selected using Page
Modes (up to three languages can be configured).

In the room, the guest can select a language from the language menu on the display. The
AntumbraDisplay then sends out a Set Language message and the Multiroom Dashboard will reflect the
chosen language. The language can also be set remotely from the Dashboard.

Set up guest languages:

1. In Site Settings > Hotel Settings > Room Profiles, select a room profile.

2. Under Features, Set Supports Guest Language to True.
Repeat this for all room profiles that require guest language options.
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 The room profile settings are also available in System Builder.

3. In Site Settings > Hotel Settings > Guest Languages, select the required languages from the
Available Languages list.

4. Click  Add to Job, to move the languages to the Selected Languages list or click  Remove to
delete them from the list.

5. To set a language as default, select the language from the list and click  Set Default Language or
you can click  Clear Default Language.

6. Click the Save button to save the current changes and close the Site Settings window.
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9.8. Configure SM Client User Access


This is only for System Manager Client users. It does not affect Dashboard users.
Dashboard users are configured in the Dashboard Web Interface.

System Manager offers a range of configurable user roles and permissions, allowing individuals the
appropriate level of control and access while removing unnecessary and restricted information from the
interface.

To access User Access Management, open  System Manager Configuration and click the Manage
Users button.


For more information on users and user roles, refer to the System Manager Installation
Guide.

In User Access Management > User Roles, the following securable service settings are recommended.
All other services should be left at their default settings unless advised by your Signify consultant.

Securable
Service

Description Recommended
Setting

Write
Button

User can create, delete and edit room tiles. Enabled for
commissioning only.

Control
Button

User can click buttons in System Manager to perform functions
such as changing room status and controlling HVAC systems.

Enabled for
authorized staff.
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Securable
Service

Description Recommended
Setting

Site Map
View
Maintenanc
e View
Reports
View
Alerts View

User can access non-Dashboard tabs in System Manager. Disabled

9.9. Configure secure Dashboard user access
Secure user access to services running on the SM Server requires user authentication and an HTTPS
certificate (for encrypted connections) on the server and/or user PCs.

9.9.1. User Authentication

User authentication is configured for the dashboard by the superadmin user who adds users and user
profiles.

Just as for Dashboard users, administrators can set up app credentials for API integrations on the
Dashboard Configuration page. For more information refer to
/GIT/multiroom/build/multiroom/latest/index.html/multiroom/2.11/dashboard_guide/configuration/i
ntegrations.html[Multiroom Dashboard > Integrations (API Access)] and the Interact Developer Portal.

9.9.2. HTTPS

You can create and configure certificates using the SM installer or the  Data Access Configuration
tool.

There are two options:

1. Select a certificate provided by the Hotel IT team (recommended). This assumes the customer has
access to the CA (certificate authority) used to create the certificate already deployed on their client
machines.

2. System Builder can create a self-signed certificate. This certificate must then be deployed by Hotel IT
to the Windows Certificate Store on all client machines that will be accessing the dashboard.

147

https://www.developer.interact-lighting.com


When one of these options is selected, System Builder will update the IIS bindings, local hosts file on the
SM Server, and the configuration files using the domain assigned for the system as defined in the
certificate.

The customer will need to configure their DNS server to direct the domain to the SM Server machine or
configure client PC hosts files - C:\Windows\System32\drivers\etc\hosts:

• dashboard.[subdomain]

• usermgmt.[subdomain]

• api.[subdomain]

• integration.[subdomain]

• dynalitecontrolapi.[subdomain]

 Self-signed certificates have an expiration of 2 years from the current date.

9.10. Open Dashboard
After installing the security certificate and adding users, users can access the dashboard by entering
their domain gateway URL, e.g. https://myhotel.example.com
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Chapter 10. Manage Deployments

Deploy bulk updates:

1. Firmware and configuration updates

2. Variable updates

10.1. Bulk firmware and configuration updates
System Builder provides a Manage Deployment feature to update firmware and configuration data for
different room profiles in the hotel.

You can select the room profile and room devices that are to be updated, the room condition and the
deployment time. Once the deployment is configured in System Builder and saved to the database then
it is executed by the System Manager deployment engine according to the room mapping table.

Deploy Firmware and Configuration updates:

1. In System Builder, open the hotel database.

2. Select File > Open Room Configurations > [the required room profile].

3. Make the configuration changes to the devices in the room profile.

4. Select File > Open Room Configurations > Master and click Yes to rebuild the Master job.

5. Select File > Manage Deployment to open the Manage Deployments window.

6. Click  Add Room Profile Deployment.

7. Select a Room Profile, enter a Deployment Name and click OK.

8. Enter a start date and time or no changes if you want it to run immediately after saving.
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9. Select the room conditions that must be present to deploy updates to the room (Checked-Out,
Unoccupied, or None).

10. Select the Deployment as enabled or disabled. If disabled, then it will still be passed to the SM
deployment engine and can be enabled at a future time in SM Configuration > Site Settings >
Deployments.

11. Click the Firmware tab and select the devices that require a firmware update.

12. For each device, enter the path to the respective firmware file. To ensure a fast and reliable
deployment, copy the firmware files to the server machine.
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
Do not use a copy on your laptop to do the update if you have a remote
connection to the system as the deployment can take many hours.


Major firmware version numbers must match to successfully update the firmware
(e.g. 1.xx > 1.xy, 2.xx > 2.yy, etc.)

13. Click the Configuration tab and select the devices to be updated. These must match the devices that
you previously modified in the room configuration.

14. Click the Target tab and select the building and floors that you want to target for the deployment.

15. Click the Apply button to stay in the window or the OK button to close the window.

16. Click  File Save to save the database.
If the start date and time has passed and deployment is enabled, it will immediately start to deploy.

If some rooms fail to meet the specified room condition (Checked-Out, Unoccupied), then the
deployment is retried every 30 minutes up to the retry limit. These properties are configurable in the 
System Manager Configuration > Site Settings > System Settings > Deployment.

Bulk firmware and configuration update progress can be monitored on the Dashboard Configuration
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page.

10.2. Bulk Variable Updates
Bulk variable updates enable hotel staff adjust default settings for different room statuses. This can be
deployed for each room profile across the entire hotel.

For more information, refer to
/GIT/multiroom/build/multiroom/latest/index.html/multiroom/2.11/dashboard_guide/configuration/
room_profiles.html[Multiroom Dashboard > Room & Suite Profiles].
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Chapter 11. Integration

Integrate hotel systems:

1. PMS

2. HotSOS/REX

3. Saflok

4. VingCard

5. CoolAutomation

6. BMS

In-room integration provides power outlet management, AV control, HVAC control, blind control, and
window/door status detection. In-room integration only requires configuration of the room control
devices.

System integration extends outside of the room to third-party network systems and requires
configuration in each relevant gateway device or in the System Manager central monitoring and
management software.

Integration gateways are generally deployed on the backbone network, meaning they are installed and
configured to operate across many rooms. The PDEG (Philips Dynalite Ethernet Gateway) or DDNG485
(RS-485 Gateway) can facilitate two-way communication for integrated site-wide intelligence.

System Manager has system-level integration options for the following third-party systems:

• Property Management Systems - Oracle Opera (ex. Fidelio) and Infor HMS

• Access Control - Saflok and VingCard

• Central HVAC Control - CoolAutomation

• Building Management Systems – BACnet

11.1. PMS integration
Our system provides two-way communication with a Property Management System (PMS) using the
FIAS protocol (Fidelio Interface Application Specification). System Manager acts as a gateway between
System Manager and the PMS.

By integrating with a PMS, we can dynamically adjust room conditioning based on the room’s check-in
status, conserving energy when the guest is checked out. We also synchronize room statuses such as
DND/MUR and can send and receive wake-up requests. You can check the status of floor gateway

connections and FIAS connections by clicking the  globe icon in the top right corner of the
dashboard.

11.1.1. Supported Actions and Commands
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Message Type Oracle Opera Infor HMS

Occupancy • Dirty, Vacant

• Dirty, Occupied

• Clean, Vacant

• Clean, Occupied

• Inspected, Vacant

• Inspected, Occupied

Authorization • Check-in

• Check-out

• Settlement

• Check-in

• Check-out

• Room move

Status • Wake-up • MUR

11.1.2. From PMS

Guest Check-In

• When a guest checks in, Opera notifies System Manager server so that the room conditions can be
adjusted accordingly.

• This status has a native matching command in Opera, their reference GI under the group Guest Data
with variable RN (Room Number).

• Example command: GI|RN2760 (Room #2760, Guest Check In).

Guest Check-Out

• When a guest checks out, Opera notifies the System Manager server so that the room statuses can
be reset, and conditions adjusted to conserve energy between stays.

• This status has a native matching command in Opera, their reference GO under the group Guest Data
with variable RN (Room Number).

• Example command: GO|RN2760 (Room #2760, Guest Check Out).

11.1.3. To PMS

Do Not Disturb/Privacy

• When the guest activates the DND status, either manually or through a linked scene (sleep-scene
etc.), the status is synchronized with the Interact Multiroom Dashboard and sent to Opera.

• This status has a native matching command in Opera, their reference DN under the group Room Data
with variables of Y (Yes Active) or N, (Not Active).

• Example command: RE|RN2760|DNY| (Room #2760, activate DND).

• If required, DND can also be mapped to the RS field.

Make Up Room

• When the guest activates the MUR status, it is synchronized with the Multiroom Dashboard and sent
to Opera.
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• This status has a native matching command in Opera, their reference RS under the group Room Data
with a variable of 1-6. Our system is mapped to the variables 2(Dirty/Occupied) and 4
(Clean/Occupied) as the Active and Not Active states. We can also map the variables to other values
as required by the hotel to match individual Opera configurations.

• Example command: RE|RN2760|RS2| (Room #2760, activate MUR as ‘Dirty/Occupied').

11.1.4. FIAS

The PMS identifies rooms with a room number whereas SM identifies rooms with an area number. To
map the data between the two systems requires a room mapping table. This is created in SB under File >
Manage Room Profiles. System Manager can integrate with more than one FIAS system at a time.
However, in SB the FIAS server can only be set to default. The FIAS server must be configured in SM.

Configure FIAS server:

1. Open  System Manager Configuration.

2. Click Site Settings > Hotel Settings > FIAS > Servers.



To create a secure FIAS connection, generate a certificate on the Oracle Fidelio
server (use the IP address of the Fidelio server). In the Local Root certification path
check the Certificate and the IP address. Export the certificate and place the
certificate in the SM server Trusted Root Certificates store.

3. Click  Add for each FIAS Server and enter the IP Address and Port number.
You can also  Delete and  Rename the FIAS Server.

4. Restart the Fidelio server and click the Connect and Disconnect buttons to test the connection.

5. Click Site Settings > Hotel Settings > FIAS > Command.

6. If applicable, select the following checkboxes:

◦ Enable custom FIAS configuration - Enter the DND/MUR > ON/OFF value as required.

◦ Enable RS command for DND

◦ Disable Wake Up command

◦ Disable Voicemail and Message Light commands

◦ Send Room Status Messages to FIAS

◦ Send Wakeup Messages to FIAS
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7. Click Site Settings > Hotel Settings > Rooms.

8. For each room, click the dropdown list in the FIAS Server column and select the appropriate FIAS
server.

9. Click the Save button.

10. Send test commands from the Fidelio server and observe the changes on the dashboard. You can
check messages in the  SM Configuration > Monitor System window.

DyNet has specific opcodes to enable the lighting control system to communicate over FIAS. System
Manager passes the following messages:

Opcode DyNet Function

4C Set Hotel Room Information

4D Request Hotel Room Information

4E Reply/Report Hotel Room Information


In any Fidelio record, Room Number RN is an alphanumeric string up to 8 characters in
length.

 Refer to DyNet public opcodes or DyNet2 opcodes spreadsheet for specific packet
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details.



The following Infor Communications commands are not supported:

• DR Message Received

• Data Swap Sync Completed

• DS Message Sent

• GI/GO Messages Sent

• DE Message Sent

The following Infor Guest Data commands are not supported:

• Names using special code page

• Set No Post Flag in HMS – NPY

PMS translation table

DyNet Sub-OpCode and
function

Message
direction

Fidelio record

00 Do Not Disturb DyNet ←
Fidelio

RE
  RN = Room number
   DNY = Set Do Not Disturb
   DNN = Clear Do Not Disturb

(Unused. Translated by SM to Room Maid Status
command.)

01 Make Up Room DyNet →
Fidelio

RE
  RN = Room number
   RS1 = Set MUR (Dirty/Vacant)
   RS4 = Clear MUR (Clean/Occupied)

02 Laundry Pickup Request DyNet ←
Fidelio

GI
  RN = Room number
   A1Y = Set Laundry Pickup
   A1N = Clear Laundry Pickup

(Unused. Translated by SM to Room Maid Status
command.)

03 Message Light Status DyNet ←
Fidelio

RE
  RN = Room number
   MLY = Set message light
   MLN = Clear message light

04 Voice Mail DyNet →
Fidelio

RE
  RN = Room number
   VMY = Set Voicemail
   VMN = Clear Voicemail
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DyNet Sub-OpCode and
function

Message
direction

Fidelio record

05 Room Service Pickup
Request

DyNet ←
Fidelio

GI
  RN = Room number
   A2Y = Set Room Service Pickup
   A2N = Clear Room Service Pickup

(Unused. Translated by SM to Room Maid Status
command.)

06 – 19 Reserved

20 Room Maid Status DyNet →
Fidelio

RE
  RN = Room number
   RS1 = Dirty/Vacant
   RS2 = Dirty/Occupied
   RS3 = Clean/Vacant
   RS4 = Clean/Occupied
   RS5 = Inspected/Vacant
   RS6 = Inspected/Occupied

Custom according to FIAS command configuration for
DND, MUR.

21 Room Alarm/Notification Not Applicable

22 Room Wakeup Request (set
wakeup alarm)

DyNet ←→
Fidelio

WR
  RN = Room number
   DA = YYMMDD
    TI = HHMMSS

For Fidelio → DyNet, both date and time must be
specified and valid.
For DyNet → Fidelio, time must be specified and valid,
but date is optional. If year, month, and day are all 0xFF
in the DyNet packet then SM will guess the correct date
up to 24 hours ahead.

23 Room Wakeup Answer DyNet →
Fidelio

WA
  RN = Room number
   DA = YYMMDD
    TI = HHMMSS

Fidelio Answer status:
  ASOK = 0 (Success)
  ASBY = 1 (Busy)
  ASUR = 2 (Unprocessable request)

The DyNet message is sent from the device after the
alarm has been actioned and the guest has been woken.
It allows Fidelio to know that the guest has woken.
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DyNet Sub-OpCode and
function

Message
direction

Fidelio record

24 Room Wakeup Clear (clear
specific or clear all alarms)

DyNet ←→
Fidelio

WC
  RN = Room number
   DA = YYMMDD
    TI = HHMMSS

To clear a specific wakeup alarm:
For Fidelio → DyNet, both date and time must be
specified and valid.
For DyNet → Fidelio, time must be specified and valid,
but date is optional. If year, month, and day are all 0xFF
in the DyNet packet then SM will guess the correct date
up to 24 hours ahead.

To clear all wakeup alarms:
For Fidelio → DyNet, date and time fields must exist but
have no data. e.g. WC|RN1043|DA|TI|
For DyNet → Fidelio, date and time in DyNet message
must have year, month, day, hour, minute, second all set
to 0xFF.

25-39 Reserved

40 Key Card Inserted Not Applicable

41 Key Card Removed Not Applicable

42 Guest Check In DyNet ←
Fidelio

GI
  RN = Room number

Only the room number RN field is decoded. All other
fields are ignored by SM.

43 Guest Check Out DyNet ←
Fidelio

GO
  RN = Room number

Only the room number RN field is decoded. All other
fields are ignored by SM.

Guest Info Change (Room
Move)
Not currently supported

DyNet ←
Fidelio

GC
  RN = Room number

Only the room number RN, RO, and both GS fields are
decoded. Other fields are ignored by SM.

This record is translated into two separate DyNet
messages - a check-out from the old room followed by a
check-in to the new room.

44-FF Reserved

11.2. HotSOS/REX integration
Amadeus HotSOS/REX is a popular hotel operations software application that supports housekeeping,
laundry, facilities, and other guest service teams. Integrating with Amadeus HotSOS/REX enables

160



Interact to push certain room statuses and alerts into the hotel operations system to help staff deliver
guest services.

Interact synchronizes the following room statuses with the HOTSOS server:

Interact HOTSOS/REX

Privacy (Do Not Disturb) DND Make Up Room

MakeUp Real-time Occupancy GuestInRoom

Set up HOTSOS/REX integration:

1. Open Site Settings > System Settings > Hotel Settings > HotSOS/REX.

2. Enter the HotSOS API Server Address.

3. Enter a Username and Password.

4. Select the Enable checkbox to start sharing status messages.


The HotSOS specification requires numeric room names. Events in SM for rooms with
non-numeric names are not sent to the HotSOS server.


Room states are monitored after the room linking logic, so updates sent to HotSOS
include room linking.



Errors, warnings, and info are logged to the SM log. If the HotSOS server certificate is
invalid or not trusted by the SM machine, it can be seen in the Detail column. If you
see errors, you need to install the HotSOS public certificate into the Windows Trusted
Certificate Store.

11.3. Saflok integration
Saflok integration enables room access control and monitoring. You must select the checkbox for
Access Control > Saflok when installing System Manager. Selecting Saflok provides an additional IIS
Server web service site. Ensure the enabled authentication configuration for the Philips Dynalite Saflok
site in IIS matches the authentication provided by the Saflok server. Saflok is a client of Interact.
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Saflok reports on the following door events:

OpCode Sub-OpCode Command

4C 80 Door Guest Entrance

4C 81 Door Staff Entrance

4C 82 Door Inside Open (Generic egress)

4C 83 Door Deadbolt Thrown

4C 84 Door Deadbolt Released

4C 85 Door Closed

A Door Guest/Staff Entrance message needs to be followed up with an Occupancy message from the
room so that the room tile will change to Occupied (Guest) or Occupied (Staff).

On the Multiroom Dashboard Room View page, access control events are shown in the Event Timeline
and the occupancy status is shown in the room status bar.

Set up Saflok integration:

1. Open Site Settings > System Settings > Hotel Settings > Saflok and set the Entrance door events
based on door open and closed messages checkbox to False.

2. Open Site Settings > Access Control > Saflok. This page shows a monitor window to display access
control events.

3. Select the Enable checkbox.

4. For the Saflok server, configure the subscription URL in the HOTEL LENS application using the
following format: \http://[hostname]:[port]/api/EventNotification

◦ [hostname] = IP address of the SM server.

◦ [port] = 3270

◦ Webservice = REST Protocol.
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11.4. VingCard integration
VingCard integration enables room access control and monitoring. Interact is a client of VingCard. SM
makes long poll HTTP(S) API calls to the ASSA ABLOY (Visionline) server and VingCard reports on the
following door events:

OpCode Sub OpCode Command

4C 80 Door Guest Entrance

4C 81 Door Staff Entrance

4C 82 Door Inside Open (Generic egress)

4C 83 Door Deadbolt Thrown

4C 84 Door Deadbolt Released

4C 85 Door Closed

A Door Guest/Staff Entrance message needs to be followed up with an Occupancy message from the
room so that the room tile will change to Occupied (Guest) or Occupied (Staff).

On the Multiroom Dashboard Room View page, access control events are shown in the Event Timeline
and the occupancy status is shown in the room status bar.

Set up VingCard integration:

1. Open Site Settings > System Settings > Hotel Settings > VingCard and set the Entrance door
events based on door open and closed messages checkbox to False.

2. Open Site Settings > Access Control > VingCard. This page shows a monitor window to display
access control events.
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3. Select the Enable checkbox.

4. Select the Send Guest Enter and Door Close Messages checkbox ONLY if there are no door
switches on the entrance doors.



The room controller sends Door Guest Entrance and Door Closed DyNet messages
when the door switch detects the door open/closed. With VingCard integration
these events are also sent out from SM when notified by VingCard. To prevent this
issue, Send Guest Enter and Door Close Message is disabled by default. Only if a
hotel does not install door switches on hotel room doors and has VingCard
integration would this setting be enabled. Staff Guest Entrance is always sent out
with VingCard integration.

5. Enter the following information to connect SM to the VingCard server:

◦ Username

◦ Password (encrypted by the application)

◦ Base Address and Port number

6. Install the Visionline software and log in to Visionline using the default System Manager credentials
"sym" and "sym". Ensure the ASSA ABLOY consultant maps the doors to the hotel room numbers, i.e.
View > Doors.

11.4.1. Changing VingCard port number

VingCard recommends installing the server on a separate machine. In that case, there should be no need
to change the port number.

When installed on the SM Server machine, the default VingCard port number 443 conflicts with the
Dashboard, which uses the same port number 443. You must change the VingCard server to a different
port number such as 2445.

Change VingCard server port number:

1. Open the following file in a text editor:
C:\ProgramData\ASSA ABLOY\Visionline\webserver\tomcat\conf\server.xml

2. On line 98, change 443 to another port number such as 2445
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3. Add a firewall rule to allow messages from this port number.

4. Restart the server machine after editing the file to load the configuration changes.

11.4.2. Establishing a secure connection to VingCard

For System Manager to trust the VingCard server, it must have a valid TLS certificate and the SM Server
machine must have the certificate imported into its certificate store. This can be done with either a self-
signed certificate (described below) or with a CA certificate. The VingCard server comes by default with
a self-signed certificate, but it is recommended to replace that with one generated specifically for the
site.



If VingCard is already installed in the hotel by a VingCard professional, then it may
already be set up with a valid SSL certificate and that certificate would already be
trusted by Windows. In this case you only need to complete the final two testing steps
below.

Install VingCard server TLS certificate:

1. Install VingCard server.

2. Create a java keystore for the server to access.
VingCard installation comes with its own copy of java’s keytool.

◦ Open cmd.exe and run the command
cd C:\ProgramData\ASSA ABLOY\Visionline\webserver\jre\bin

◦ Run the command below (set your own values for the items in bold):

keytool -genkey -keyalg RSA -alias mykeyalias -keystore keystoreIAH.jks -storepass
strongpassword -validity 7300 -keysize 2048 -dname "CN=172.27.89.23" -ext
"SAN=IP:172.27.89.23,IP:127.0.0.1"

◦ Press Enter to accept key password is same as keystore password.

◦ If your VingCard server is on the same machine as SM, then you only need one subject
alternative name. Change the last part to -ext "SAN=IP:127.0.0.1”.

3. Export certificate from the keystore.
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◦ Run the command below (set your own values for the items in bold to match the values used in
the previous step):

keytool -export -alias mykeyalias -keystore keystoreIAH.jks -rfc -file
X509_certificate.cer

◦ You will be prompted for the keystore password.

4. Set up Apache Tomcat to use the new keystore.

◦ Copy keystoreIAH.jks to
C:\ProgramData\ASSA ABLOY\Visionline\webserver\tomcat\conf\

◦ Edit the highlighted items in this file:
C:\ProgramData\ASSA ABLOY\Visionline\webserver\tomcat\conf\server.xml

5. Import the certificate to Windows certificate store.
(We recommend doing the remaining steps on the VingCard machine first, as a test.)

◦ Copy the file X509_certificate.cer to the SM Server machine.

◦ Double-click the certificate in Windows Explorer (if prompted, choose to open with Crypto Shell
Extensions).

◦ Click Install Certificate…

◦ Select Store Location = Local Machine (you need admin rights for this) and click Next.

◦ Select Place all certificates in the following store = Trusted Root Certification Authorities and
click Next and Finish.

6. Restart the VingCard machine to load Tomcat configuration changes.

7. Test in a browser.

◦ Point a browser to the VingCard server IP address (e.g. https://172.27.89.23:2445).
Use Chrome or Edge for this step, as Firefox has its own certificate store.

◦ Make sure the IP/port is not blocked by the firewall. You should see the Tomcat server
homepage with a valid secure connection.
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8. Check that SM is connected to the VingCard server.

◦ You may need to restart SM Server to confirm the changes to the certificate store.

◦ Check the log in  System Manager Configuration - you should not see this error.

11.5. CoolAutomation Integration
Integration with the CoolAutomation HVAC control system enables centralized and in-room HVAC
control and monitoring. Integration is performed with a CoolMasterNet bridge in combination with
dedicated HVAC Ethernet gateways and AntumbraDisplay user interfaces.


One CoolMasterNet gateway can support up to 6 simultaneous TCP connections. If
there are more than six Ethernet gateways to be connected, add more CoolMasterNet
gateways or consult with a CoolMaster technician to overcome this limitation.


Only one-way communication is possible in the current CoolMaster task template. Any
changes made to HVAC settings outside of the AntumbraDisplay will not be updated
in the panel.

 The task template can work in both PDDEG-S and PDEG Ethernet gateways.

Configure a floor gateway port for CoolMasterNet gateway integration:

1. In the PDDEG-S/PDEG Ports Editor, click  Add > IPv4 port and select the following:

◦ Port type: Text and Binary Integration

◦ Mode: Client

◦ IP Address: The supplied address for the CoolMasterNet gateway.

◦ Port Number: Unless specified otherwise, 10102 is the CoolMasterNet gateway default.

◦ Protocol: TCP
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2. Open the master job file and select a floor gateway. Then in the Tasks Editor click  Select Task
Template and choose IAH-Coolmaster Integration-PDEG.evt.


IAH-CoolMaster task templates are available in System Builder from
STR/Multiroom v2.3 (System Builder v3.31.8) onwards.


Ensure that you choose the correct IAH-specific task template, not the Coolmaster
task template for Dynalite projects.

3. In the task template, under Parameters, enter the HVAC Line configured in the CoolMasterNet
gateway, Port Index of the TCP port created in the PDDEG-S/PDEG that is connected to the
CoolMasterNet gateway, and the Number of HVAC Units mapped for integration.
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4. In the HVAC GRMS Mapping [unit number] section, enter the following details:

◦ Enabled: True - enables mapping and opens the related configuration settings.

◦ AlphaNumeric Indoor Num:

▪ False if HVAC unit number is only numeric.

▪ True if HVAC unit number is alphanumeric (e.g A01, F04, etc.), enabling two new properties:

▪ Alphabet Part of HVAC Indoor Num

▪ Numeric Part of HVAC Indoor Num

▪ e.g. if the unit is F03, enter F and 3 in the respective fields. 0 does not have to be
specified.

5. Set HVAC Indoor Number > 255 to:

◦ False if HVAC unit number is below 255.

◦ True if HVAC unit number is above 255 (2 bytes), e.g. 301, 505, 515 etc.
As the task can only handle 1-byte values for processing, numbers over 255 must be split and
entered as First 2 Digits and Last digit(s) (everything after the first two digits).

169



6. HVAC Indoor Number: If the HVAC Indoor number is not alphanumeric and the value is below 255,
enter the value directly in this text field.

7. GRMS Box Number: Each HVAC unit will be mapped to the corresponding room via the GRMS box
number. Enter the GRMS box number for the room that is connected to the HVAC unit number
mentioned in the previous steps.

8. Feed Temp Support: True ONLY if the HVAC unit supports and uses the temperature recorded by
third-party sensors such as Antumbra.

9. Configure bouncer tasks in one of the room devices to convert the STR-specific HVAC control preset
messages to channel level messages that are used in the CoolMaster template.

◦ Open the room profile job file and select one of the room devices other than the HVAC
Antumbra Panel - preferably a device with no other tasks running on it.
In the example shown below, the bouncer tasks are copied to the bedroom sensor.

◦ Select the device, then in the Tasks editor, click  Select Task Template and choose IAH-
Coolmaster Integration-BouncerTask.evt.
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◦ The task will convert the Multiroom HVAC preset messages to CoolMaster-specific channel level
messages.
Also, setpoint temperature changes from the Multiroom Dashboard will be forwarded to the
CoolMasterNet gateway.

◦ Repeat this procedure for each room using CoolMaster integration.

11.6. BMS integration
To integrate System Manager with building management systems such as HVAC and power, or link to
networked systems, we provide a range of open protocol and proprietary integration options including
BACnet, Modbus, and CoolAutomation.

11.6.1. BACnet

BACnet integration allows the BMS to trigger tasks and time-based events by recalling presets in the
Multiroom system, and enables the system to report current system status to the BMS.

The BACnet gateway provides:

• Read/Write access for preset control, channel level control, and HVAC temperature control.

• Read access for HVAC temperature reporting, sensor light values, DALI driver status, and device
status.

For more information refer to:
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• CoolAutomation Integration

• System Builder > Ethernet Gateways

• System Builder > Modbus Power Meters

172

https://docs.dynalite.com/system-builder/latest/ethernet_gateways.html
https://docs.dynalite.com/system-builder/latest/modbus.html


Chapter 12. Handover
The commissioning engineer:

• Requests that the customer’s IT team configures HTTPS access to the Multiroom Dashboard by
installing a TLS certificate (cannot be used without).

• Ensures preprogrammed rooms are connected to our server, loaded onto the Dashboard, and made
ready for use.

• Checks System Manager and Dashboard functionality.

• Tests integration functionality.

• Documents the as-built system (functionality list, single-line drawings, as-installed drawings from
electrical contractor).

• Delivers training (how to use the Dashboard, user management, emergency lighting testing).

• Provides reference and support information.

• Receives customer handover sign-off.

• Confirms services, warranties, and maintenance agreements are in effect.
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